напишите программу, которая генерирует массив из 15 элементов, который заполнен случайным образом целыми числами от -15 до 15, и находит сумму всех чисел массива, которые кратны 3
Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.
Программа может выглядеть так:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do begin
s:=s+i; {Вычисление суммы чисел}
i:=i+4; {Увеличение значения параметра i на 4}
end;
writeln ('s=',s) {Вывод результата суммы s}
end.
Можно решить данную задачу и вторым используя операцию mod:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do
if i mod 5=0 {Поиск чисел, кратных 5}
then s:=s+i; {Вычисление суммы чисел}
writeln ('s=',s); {Вывод результата суммы s}
end.
ответом будет s=275.
Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.
program zadacha;
uses crt;
var x,y,i:integer;
begin
for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;
Составим программу вычисления суммы ряда чисел 5, 10, 15, …, 50 на языке программирования Pascal ABC. Введем обозначения следующих величин: пусть s – сумма чисел ряда, которую надо найти, а i – порядковый номер чисел ряда. Начальное значение суммы s будет равным нулю. Так как чисел несколько, то будем использовать в программе оператор цикла с параметром for. По условию задачи числа суммируются, начиная с числа 5, с интервалом 4 числа, поэтому значение i в каждом цикле будем увеличивать на 4.
Программа может выглядеть так:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do begin
s:=s+i; {Вычисление суммы чисел}
i:=i+4; {Увеличение значения параметра i на 4}
end;
writeln ('s=',s) {Вывод результата суммы s}
end.
Можно решить данную задачу и вторым используя операцию mod:
program zadacha;
uses crt;
var s,i: integer;
begin
s:=0; {Задание начального значение суммы s}
for i:=5 to 50 do
if i mod 5=0 {Поиск чисел, кратных 5}
then s:=s+i; {Вычисление суммы чисел}
writeln ('s=',s); {Вывод результата суммы s}
end.
ответом будет s=275.
Составить программу нахождения значения функции у= 5х+х2, при х=50, 49, 48, 47, …, 40.
program zadacha;
uses crt;
var x,y,i:integer;
begin
for i:=50 downto 40 do begin y:=5*i+i*2; writeln ('y=',y); end;
writeln ('y=',y)
end.
Объяснение:
C Lang
#include <ctype.h>
#include <errno.h>
#include <stdio.h>
#include <stdlib.h>
#include <sys/ioctl.h>
#include <termios.h>
#include <unistd.h>
/*** defines ***/
#define CTRL_KEY(k) ((k) & 0x1f)
/*** data ***/
struct editorConfig {
int screenrows;
int screencols;
struct termios orig_termios;
};
struct editorConfig E;
/*** terminal ***/
void die(const char *s) {
write(STDOUT_FILENO, "\x1b[2J", 4);
write(STDOUT_FILENO, "\x1b[H", 3);
perror(s);
exit(1);
}
void disableRawMode() {
if (tcsetattr(STDIN_FILENO, TCSAFLUSH, &E.orig_termios) == -1)
die("tcsetattr");
}
void enableRawMode() {
if (tcgetattr(STDIN_FILENO, &E.orig_termios) == -1) die("tcgetattr");
atexit(disableRawMode);
struct termios raw = E.orig_termios;
raw.c_iflag &= ~(BRKINT | ICRNL | INPCK | ISTRIP | IXON);
raw.c_oflag &= ~(OPOST);
raw.c_cflag |= (CS8);
raw.c_lflag &= ~(ECHO | ICANON | IEXTEN | ISIG);
raw.c_cc[VMIN] = 0;
raw.c_cc[VTIME] = 1;
if (tcsetattr(STDIN_FILENO, TCSAFLUSH, &raw) == -1) die("tcsetattr");
}
char editorReadKey() {
int nread;
char c;
while ((nread = read(STDIN_FILENO, &c, 1)) != 1) {
if (nread == -1 && errno != EAGAIN) die("read");
}
return c;
}
int getCursorPosition(int *rows, int *cols) {
char buf[32];
unsigned int i = 0;
if (write(STDOUT_FILENO, "\x1b[6n", 4) != 4) return -1;
while (i < sizeof(buf) - 1) {
if (read(STDIN_FILENO, &buf[i], 1) != 1) break;
if (buf[i] == 'R') break;
i++;
}
buf[i] = '\0';
if (buf[0] != '\x1b' || buf[1] != '[') return -1;
if (sscanf(&buf[2], "%d;%d", rows, cols) != 2) return -1;
return 0;
}
int getWindowSize(int *rows, int *cols) {
struct winsize ws;
if (ioctl(STDOUT_FILENO, TIOCGWINSZ, &ws) == -1 || ws.ws_col == 0) {
if (write(STDOUT_FILENO, "\x1b[999C\x1b[999B", 12) != 12) return -1;
return getCursorPosition(rows, cols);
} else {
*cols = ws.ws_col;
*rows = ws.ws_row;
return 0;
}
}
/*** output ***/
void editorDrawRows() {
int y;
for (y = 0; y < E.screenrows; y++) {
write(STDOUT_FILENO, "~", 1);
if (y < E.screenrows - 1) {
write(STDOUT_FILENO, "\r\n", 2);
}
}
}
void editorRefreshScreen() {
write(STDOUT_FILENO, "\x1b[2J", 4);
write(STDOUT_FILENO, "\x1b[H", 3);
editorDrawRows();
write(STDOUT_FILENO, "\x1b[H", 3);
}
/*** input ***/
void editorProcessKeypress() {
char c = editorReadKey();
switch (c) {
case CTRL_KEY('q'):
write(STDOUT_FILENO, "\x1b[2J", 4);
write(STDOUT_FILENO, "\x1b[H", 3);
exit(0);
break;
}
}
/*** init ***/
void initEditor() {
if (getWindowSize(&E.screenrows, &E.screencols) == -1) die("getWindowSize");
}
int main() {
enableRawMode();
initEditor();
while (1) {
editorRefreshScreen();
editorProcessKeypress();
}
return 0;
}