В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mariadenisovna
mariadenisovna
08.09.2021 08:35 •  Информатика

Напишите программу, которая будет выводить на экран элементы последовательности трибоначчи- первые элементы последовательности: 0,0,1,1,2,4,7,13,24,44 81,149.. каждый элемент, начиная с четвертого, равен сумме трех предыдущих: an= an-1 + an-2 + an-3

Показать ответ
Ответ:
lassdeavs
lassdeavs
23.03.2020 16:00

Как я понял,нужно было вывести главную и побочную диагонали.

Ошибки:

пропущены скобки,как обычные так и фигурные;пропущены знаки ";","<" и т.д.;

Легче было заново написать чем исправлять.

Вот мой код:

import java.util.Scanner;

public class Main{

public static void main (String [] args){

 Scanner in = new Scanner (System.in);

 int n = in.nextInt();  

 int mass[][] = new int [n][n];

 int i,j;

 

 for(i=0;i<n;i++){

  for(j=0;j<n;j++){

   mass[i][j]=in.nextInt();

  }

 }

 

 for(i=0;i<n;i++){

  for(j=0;j<n;j++){

   if((i==j) || j==(n-1-i)){

    System.out.print("x");

   }else System.out.print(mass[i][j]);

   

  }

  System.out.println();

 }

 

 in.close();  

}

}

Объяснение:

Краткий алгоритм программы:Импортируем Scanner;Объявляем переменную in типа Scanner,для ввода;Объявляем переменную n типа int,для хранения размера массива;Объявляем две переменные i и j типа int,для циклов;В первом "двойном" цикле мы заполняем массив числами;Во втором "дойном" цикле мы мы сравниваем индексы массива и выводим результат;Закрываем Scanner;
0,0(0 оценок)
Ответ:
kostyaluch
kostyaluch
19.02.2021 11:52
//Pascal ABC.NET v3.0 сборка 1111

Const
 n=7;

Var
 ar:array[1..n] of integer; //массив дней
 i,k:integer;
 sr:real;
begin
k:=0; //счётчик превысивших
 for i:=1 to n do
   begin
   readln(ar[i]); //вводим дни
   sr:=sr+ar[i]; //заодно вычисляем сумму дневных температур
  end;
 sr:=sr/n; {делим сумму на количество дней, получаем среднюю температуру}
 for i:=1 to n do
   if sr<ar[i] then inc(k); {если температура некотрого для выше средней, увеличиваем счётчик}
 writeln('Средняя температура=',sr,', за неделю ', k,' дней превысили эту температуру');
end.

Пример ввода:
1
2
...
7
Пример вывода:
Средняя температура=4, за неделю 3 дней превысили эту температуру
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота