В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dianka2712
dianka2712
15.01.2020 05:50 •  Информатика

Напишите программу, которая будет считывать с клавиатуры пароль и проверять соответствует ли
введенный пароль требованиям и возвращает True,
если соответствует и False, если нет. Пароль должен
содержать:

а) буквы (регистр не важен)

б) как минимум одну цифру

А также НЕ должен содержать пробелов.

Показать ответ
Ответ:
laura050027
laura050027
30.04.2021 15:27

python

password  = input()

have_letter = False

have_diggit = False

have_space = False

for i in password:

 if i.isalpha():

   have_letter = True

 elif i.isdigit():

   have_diggit = True

 elif i == ' ':

   have_space = True

if have_letter and have_diggit and not have_space:

 print(True)

else:

 print(False)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота