В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ikonnikoval
ikonnikoval
01.05.2023 15:41 •  Информатика

Напишите программу, которая будет находить все пары положительных целых чисел, произведение которых будет равно значению value. Например, если ввести число б, программа должна выдать следующий результат: 1*6 2*3 3*2 6*1

Показать ответ
Ответ:
Тамик999
Тамик999
05.06.2023 15:47
Const m=4; n=15;
var
  i,j,j0: integer;
  a:array[1..m,1..n] of integer;
  jExit,iExit:Boolean;
begin
  Randomize;
  for i:=1 to m do begin
    writeln;
    for j:=1 to n do begin
      a[i,j]:=random(2);
      write(a[i,j]:2)
      end
    end;
  writeln;
  j:=0; jExit:=false;
  repeat
    j:=j+1; i:=1; iExit:=false;
    if a[i,j]=0 then begin
      repeat
        i:=i+1;
        if a[i,j]<>0 then iExit:=true
      until iExit or (i=m);
      if i=m then jExit:=true
      end
    until jExit or (j=n);
  if a[i,j]=0 then writeln('Нулевой столбец ',j)
  else writeln('Нет нулевых столбцов');
end.

Тестовый пример:

 0 1 1 1 1 0 1 0 1 0 0 0 0 0 1
 0 0 1 0 1 0 0 0 1 1 0 0 0 0 0
 1 1 0 0 0 1 0 1 1 1 1 1 0 1 1
 1 1 1 0 1 0 1 0 0 1 0 1 0 1 0
Нулевой столбец 13
0,0(0 оценок)
Ответ:
Artemmundryl
Artemmundryl
14.06.2021 02:28
 основные возможности ос windows 
Windows обеспечивает доступность базовых средств ОС в столь непохожих друг на друга системах, как мобильные телефоны, карманные устройства, переносные компьютеры и серверы масштаба предприятия. Возможности ОС можно охарактеризовать, рассмотрев наиболее важные ресурсы, которыми управляют современные операционные системы.• Память. ОС управляет сплошным, или плоским (flat), виртуальным адресным пространством большого объема, перемещая данные между физической памятью и диском или иным накопительным устройством прозрачным для пользователя образом.• Файловые системы. ОС управляет пространством именованных файлов, предоставляя возможности прямого и последовательного доступа к файлам, а также средства управления файлами и каталогами. Используемые в большинстве систем пространства имен являются иерархическими.• Именование и расположение ресурсов. Файлы могут иметь длинные, описательные имена, причем принятая схема именования распространяется также на такие объекты, как устройства, а также объекты синхронизации или межпроцессного взаимодействия. Размещение именованных объектов и управление доступом к ним также являются прерогативой ОС.• Многозадачность. ОС должна располагать средствами управления процессами, потоками и другими единицами независимо выполняться в асинхронном режиме. Задачи могут планироваться и вытесняться в соответствии с динамически определяемыми приоритетами.• Взаимодействие и синхронизация. ОС управляет обменом информацией между задачами и их синхронизацией в изолированных системах, а также взаимодействием сетевых систем между собой и сетью Internet.• Безопасность и защита. ОС должна предоставлять гибкие механизмы защиты ресурсов от несанкционированного или непреднамеренного доступа и нанесения ущерба системе.Microsoft Windows Win 32/Win64 API обеспечивает поддержку не только этих, но и множества других средств ОС, и делает их доступными в ряде версий Windows, некоторые из которых постепенно выходит из употребления, а некоторые поддерживает лишь то или иное подмножество полного API.

Классификация операционных систем
в зависимости от алгоритма управления процессором, операционные системы делятся на:Однозадачные и многозадачные
Однопользовательские и многопользовательские
Однопроцессорные и многопроцессорные системы
Локальные и сетевые.По числу одновременно выполняемых задач операционные системы делятся на два класса:Однозадачные (MS DOS)Многозадачные (OS/2, Unix, Windows)В зависимости от областей использования многозадачные ОС подразделяются на три типа:Системы пакетной обработки (ОС ЕС)
Системы с разделением времени (Unix, Linux, Windows)
Системы реального времени (RT11)
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота