В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Raterford
Raterford
21.04.2023 11:20 •  Информатика

Напишите программу, которая будет 5 раз генерировать два случайных числа от 1 до 10 и сохранять их в переменные x и y. После этого, программа будет спрашивать у пользователя сумму двух переменных x и y.

Если пользователь отвечает правильно, то программа начисляет ему Иначе она будет просто выводить правильный ответ.

Не забудь вывести итоговый счет, ведь всем интересно насколько хорошо они отвечали

Показать ответ
Ответ:
erteeq
erteeq
02.07.2021 18:38

import random

score = 0

for i in range(5):

   x = random.randint(1, 10)

   y = random.randint(1, 10)

   print("Введите сумму")

   inp = int(input())

   if x + y == inp:

       print("Верно!")

       score += 1

   else:

       print("Правильный ответ -", x + y)

print("Итоговый счёт:", score)

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота