В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
CwetochekAnfisa
CwetochekAnfisa
26.03.2022 03:33 •  Информатика

Напишите программу к этой для visual basic имеется массив к из nцелых чисел. составьте алгоритм подсчета, сколько раз число 5 встречается среди элементов данного массива, иначе сообщить: «таких нет».

Показать ответ
Ответ:
Bakc1
Bakc1
07.10.2020 07:34
#include <iostream>
#include <vector>
using namespace std;
int main() {
int n, x, five = 0;
cin >> n;
vector <int> k;
for (; n > 0; cin >> x, k.emplace_back(x), n--);
for (int i = 0; i < k.size();) {
 if (k[i++] == 5)
  ++five;
}
if (five == 0)
 cout << "There is no such";
else
 cout << five;
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота