В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
alina06122
alina06122
26.06.2022 16:12 •  Информатика

Напишите программу, используя repeat или while, которая вычислит на какой день число вылупившихся из яйца утят станет больше 120, если известно что в инкубаторе в 1-ый день вылупилось 5 утят, а в каждый последующий день вылупливалось на 10 утят больше, чем в предыдущий. Паскаль.

Показать ответ
Ответ:
Тамик999
Тамик999
05.06.2023 15:47
Const m=4; n=15;
var
  i,j,j0: integer;
  a:array[1..m,1..n] of integer;
  jExit,iExit:Boolean;
begin
  Randomize;
  for i:=1 to m do begin
    writeln;
    for j:=1 to n do begin
      a[i,j]:=random(2);
      write(a[i,j]:2)
      end
    end;
  writeln;
  j:=0; jExit:=false;
  repeat
    j:=j+1; i:=1; iExit:=false;
    if a[i,j]=0 then begin
      repeat
        i:=i+1;
        if a[i,j]<>0 then iExit:=true
      until iExit or (i=m);
      if i=m then jExit:=true
      end
    until jExit or (j=n);
  if a[i,j]=0 then writeln('Нулевой столбец ',j)
  else writeln('Нет нулевых столбцов');
end.

Тестовый пример:

 0 1 1 1 1 0 1 0 1 0 0 0 0 0 1
 0 0 1 0 1 0 0 0 1 1 0 0 0 0 0
 1 1 0 0 0 1 0 1 1 1 1 1 0 1 1
 1 1 1 0 1 0 1 0 0 1 0 1 0 1 0
Нулевой столбец 13
0,0(0 оценок)
Ответ:
fatima6969
fatima6969
24.08.2022 14:27

1)Что такое поле БД?  (ответ) Поле базы данных - это столбец таблицы, содержащий значения определенного свойства. Строки таблицы являются записями об объекте; эти записи разбиты на поля столбцами таблицы, поэтому каждая запись представляет собой набор значений, содержащихся в полях.

2) Для чего нужно связывать таблицы в БД?

(ответ) Многие СУБД при связывании таблиц автоматически выполняют контроль целостности вводимых в базу данных в соответствии с установленными связями. В конечном итоге это повышает достоверность хранимой в БД информации.

3)  Что такое База данных? (ответ) представленная в объективной форме совокупность самостоятельных материалов, систематизированных таким образом, чтобы эти материалы могли быть найдены и обработаны с электронной вычислительной машины

4)В каком режиме могут создаваться поля БД?

(ответ)

*создание таблицы в режиме конструктора;

*создание таблицы с мастера;

*создание таблицы путем ввода данных

5)  Если между таблицами БД установлены связи, то к чему может привести  изменение или удаление существующих полей? (ответ) Каждая запись в таблице "Сведения о заказах" содержит значение поля "КодТовара", которому соответствует запись в таблице "Товары" с тем же значением в данном поле. тут не уверен честно

6) Что такое ключевое поле БД?  (ответ)Ключевое поле — это одно или несколько полей, комбинация значений которых однозначно определяет каждую запись в таблице. Если для таблицы определены ключевые поля, то Microsoft Access предотвращает дублирование или ввод пустых значений в ключевое поле.

7) Назовите два основных этапа создания БД (ответ) Определить структуру базы данных и типа каждого поля. 2. Ввод данных. ... Поиск информации в базе данных на основе критериев поиска

8)При чего можно создать формы ввода данных в таблицу

(ответ)

инструмента Form;

инструмента Разделенная form;

инструмента Несколько элементов;

инструмента Пустая form;

Мастера form;

Конструктора form.

9)Приведите примеры типов полей (из разобранного видеоматериала)

(ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

10)Приведите примеры типов полей из разобранного видеоматериала (ответ) Каждая таблица в Access состоит из полей. В свойствах поля описываются характеристики и поведение добавляемых в него данных. Тип данных поля — это самое важное свойство, которое определяет, какие данные могут храниться в поле. В этой статье описаны типы данных и другие свойства поля, доступные в Access, а также приведена дополнительная информация в разделе справочных сведений о типах данных.

11)Опишите тип поля счетчик своими словами (ответ) новое поле предназначенное для хранения часто изменяющихся целочисленных данных

12)Из каких файлов можно импортировать данные в таблицу БД? (ответ) импортировать таблицы, за формы, отчеты, макросы и модули из одной базы данных Access в другую. При импорте Access создает копию объекта в текущей базе данных.

(вроде всё!)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота