В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
azerzhanovaa
azerzhanovaa
30.06.2021 22:26 •  Информатика

Напишите программу генерации одномерного массива из 10 целых элементов в диапазоне от -6 до +17.

Показать ответ
Ответ:
annablakfare303030
annablakfare303030
23.01.2020 10:06

unit math;

var

   d,m:array[1..20] of integer;

   sr:real;

   kol,s:integer;

Begin

  for i:=1 to 20 do begin

    d[i]:=RandomRange(140,180);

    writeln('Рост ',i,'-ой девочки =',d[i],' см');

    m[i]:=RandomRange(140,190);

    writeln('Рост ',i,'-го мальчика= ',m[i],' см');

  end;

 s:=0;sr:=0;kol:=0;

 for i:=1 to 20 do s:=s+m[i];

 sr:=s/20;

 writeln('Средний рост мальчиков= ',sr,' см');

 for i:=1 to 20 do

  if d[i]>sr then kol:=kol+1;

 writeln('Колличество девочек превышающий средний рост мальчиков= ',kol);

End.

 

0,0(0 оценок)
Ответ:
yaku06nastyaozq1r7
yaku06nastyaozq1r7
08.02.2022 04:54

Program n1;
Uses CRT;
Var A,B,C,sum: array[1..100] of Integer; srb: array[1..100] of Real;
i,k,n: integer; sr: real;
begin
ClrScr;
randomize;
Writeln('Vvedite kol-vo figuristov');
Readln(n);
Writeln('Rezultaty');
For i:=1 to n do
begin
a[i]:=random(10);
write(a[i]:4);
end;
writeln;
For i:=1 to n do
begin
b[i]:=random(10);
write(b[i]:4);
end;
writeln;
For i:=1 to n do
begin
c[i]:=random(10);
write(c[i]:4);
end;
writeln;
Writeln('Summa ballov');
For i:=1 to n do
begin
sum[i]:=a[i]+b[i]+c[i];
write(sum[i]:4);
srb[i]:=sum[i]/3;
if srb[i]>sr then begin sr:=srb[i]; k:=i; end;
end;
writeln;
Writeln('Srednii rezultat');
For i:=1 to n do
write(srb[i]:4:2,' ');
writeln;
writeln('Pobedil figurist ',k,' s rezultatom ',sr:2:2);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота