В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
angelnoya1
angelnoya1
20.07.2022 21:38 •  Информатика

Напишите программу формирования и вывода массива размером 6 х 3, каждые три последовательных элемента в строке которого составлены по следующему правилу: 1-ый -- равен случайному числу; 2-ой -- равен целой части квадратного корня из предыдущего элемента; 3-ий -- равен сумме двух предыдущих элементов.

Показать ответ
Ответ:
alinag13052005
alinag13052005
07.07.2020 17:28
Var
  i, j: integer;
  a: array[1..6, 1..3] of real;
  b: real;

begin
  Randomize;
  for i := 1 to 6 do
  begin
    b := random(1000);
    a[i, 1] := b;
    a[i, 2] := int(sqrt(b));
    a[i, 3] := b + a[i, 2];
    writeln(a[i, 1], ' ', a[i, 2], ' ', a[i, 3])
  end
end.

Результат работы программы в PascalABC.NET:
61 7 68
291 17 308
3 1 4
515 22 537
236 15 251
571 23 594
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота