В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
MyNyanKet
MyNyanKet
02.09.2020 22:37 •  Информатика

Напишите программу для вычислите значения выражений на языке Python:
Подпись отсутствует
сорр

Показать ответ
Ответ:
llllllllllllll1
llllllllllllll1
07.11.2021 00:19

Объяснение:

var a,b:real; c,e:integer;

begin

writeln('Введите два целых числа');

readln(a);

// нет ввода второго целого числа. надо написать readln(b);

c:=a/b; //ошибка! при делении может получится дробное число, а с указано как целое

d:=a mod b; //переменная d не описана в разделе var

e:=c+d;

writeln(c);

writeln(d);

writeln(e);

end.

Готовая программа:

var c, e:real; a,b,d:integer;

begin

writeln('Введите два целых числа');

readln(a);

readln(b);

c:=a/b;

d:=a mod b;

e:=c+d;

writeln(c);

writeln(d);

writeln(e);

end.

0,0(0 оценок)
Ответ:
artemmaslov25Artem
artemmaslov25Artem
10.07.2020 11:59

from random import randint

class G:

def __init__(self):

 self.wins = 0

def menu(self):

 print("stop - для остановки решения\nEnter продолжение.")

 while 1:

  if self.wins > 5:

   print("Ты хорошо справился, думаю на сегодня хватит")

   G.result(self)

   break

  a = input(": ")

  if a == "stop":

   G.result(self)

   break

  elif a == "":

   G.game(self)

  else: pass

def game(self):

 n1,n2 = randint(1,100),randint(1,100)  # примеры от и до

 print(f"Сколько будет: {n1} + {n2}?")

 if int(input("ответ: ")) == n1+n2:

  print("Верно")

  self.wins += 1

 else:

  print("Неверно")

 if self.wins != 5+1:

  print("Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания")

def result(self):

 print("игра остановлена")

 print(f"Количество верных ответов: {self.wins}")

 if self.wins > 5:

  print("Молодец!")

 else:

  print("Потренируйся ещё")

a = G()

a.menu()


Напишите программу на python которая генерирует случайный пример на сложение двух чисел, например
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота