В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
isa2221
isa2221
22.01.2022 17:55 •  Информатика

напишите программу для вычисления площади прямоугольника со сторонами а, б. введите с клавиатуры длины сторон а, б. программа должна найти одно число — площадь прямоугольника

Показать ответ
Ответ:
zinabantaeva407
zinabantaeva407
05.12.2021 08:00

ОбъясОтличник

program prog;

uses crt;

var a,b,v:integer;

begin

clrscr;

write('Возраст Антона = ');

readln(a);

write('Возраст Бориса = ');

readln(b);

write('Возраст Виктора = ');

readln(v);

writeln;

if (a>b)and(a>v) then writeln('Антон старше всех.');

if (b>a)and(b>v) then writeln('Борис старше всех.');

if (v>a)and(v>b) then writeln('Виктор старше всех.');

if (a=b)and(a>v) then writeln('Антон и Борис старше Виктора');

if (a=v)and(a>b) then writeln('Антон и Виктор старше Бориса');

if (b=v)and(b>a) then writeln('Борис и Виктор старше Антона');

if (a=b)and(a=v) then writeln('Антон,Борис и Виктор одного возраста');

end.

Подробнее - на -

0,0(0 оценок)
Ответ:
avramenkoviola
avramenkoviola
22.03.2020 03:32
Наибольшее возможное значение выражения (F+O+X+E)*(F*R*D*D) = 236196. Прилагаю небольшой скрипт на Python. Простенькая задачка на корректную организацию перебора с использованием вложенных циклов:

max_num = 0
for f in xrange(10):   
    for o in xrange(10):
        for x in xrange(10):
            for e in xrange(10):
                 for r in xrange(10):
                      for d in xrange(10):
                            b = f*r*d*d
                            if b == 0:
                                 continue
                            num = (f + o + x + e) * b
                            if num > max_num:
                                 max_num = num

print "Maximum value of (F+O+X+E)*(F*R*D*D) is: %i" % max_num

Решение можно получить гораздо проще, если догадаться, что наибольшее значение выражения достигается, когда сумма F+O+X+E и произведение F*R*D*D являются максимальными. Это одновременно происходит, когда все цифры равны 9: (9+9+9+9)*9*9*9*9 = 236196
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота