Напишите программу для создания изображения. раскрасьте данное изображение по своему усмотрению. дополнительные команды для построения графическихпримитивов можно найти в справочной системе. зделайте команды что бы сделать робота,
Довгий час знання, яких набувала людина протягом життя, передавались усно від покоління до покоління, що не забезпечувало безперервного поповнення бази знань людства в цілому. Безперервний процес збереження інформації забезпечила писемність, яка дозволяла накопичувати інформацію.
Спочатку люди викарбовували написи на камінні, потім видавлювали гострими паличками на глиняних дощечках. Писали паличками на папірусі, пензликами на шовку і перами на папері. Гусяче перо змінили ручки з металевим пером, а їх – графітові олівці, авторучки, а згодом друкарські машини.
Проте в роботі з текстами залишалося незмінним головне: щоб внести зміни в текст, його потрібно було щоразу переписувати або передруковувати. І лише застосування комп'ютерів і спеціальних програм принципово змінило технологію роботи з текстом. У чому ж полягають переваги у використанні ПК для обробки текстів?
Для роботи з текстом на ПК використовують: текстові редактори, текстові процесори та видавничі системи. У загальному їх називають системами обробки текстів – програми, які призначені для створення, редагування й друку текстових документів.
Текстовий редактор – це програма, що дозволяє вводити, редагувати, форматувати та зберігати текст.
Текстовий процесор – це програма, що дозволяє вводити, редагувати й форматувати текст, вставляти малюнки й таблиці, перевіряти правопис, складати зміст, виконувати перенос слів та багато інших складних операцій.
Настільна видавнича система (НВС) – це програма, за до якої можна створювати високоякісні оригінал-макети, що містять текст і графічні зображення для тиражування в друкарні.
• текстові процесори (Microsoft Word, Word Prefect, OpenOffice, Word-Star);
• настільні видавничі системи (Adobe PageMaker, Corel Ventura, Publisher, QuarkXPress).
Вивчаючи в 9-му класі роботу з текстовим процесором Word 2003, ви вже навчилися створювати текстові документи, редагувати і форматувати текст, вставляти в документ і форматувати векторні графічні зображення. Однак користувач майже завжди передбачає, що створений ним документ буде надрукований. Тому важливо оформити документ так, щоб він гарно виглядав не тільки на екрані, але й на аркуші паперу.
var
s: string;
i, count: integer;
begin
writeln('Vvedite stroky: ');
readln(s);
for i := 1 to length(s) - 2 do
if copy(s, i, 3) = 'abc' then
count := count + 1;
writeln('Kol-vo: ', count);
end.
2.
var
s1, s2: string;
i, len1, len2: integer;
begin
writeln('Vvedite stroky 1: ');
readln(s1);
writeln('Vvedite stroky 2: ');
readln(s2);
len1 := length(s1);
len2 := length(s2);
if len1 > len2 then writeln('1 stroka dlinnee')
else if len1 < len2 then writeln('2 stroka dlinnee')
else writeln('dlini strok ravnie')
end.
3.
var
s1, s2, s3: string;
begin
writeln('Vvedite stroky 1: ');
readln(s1);
writeln('Vvedite stroky 2: ');
readln(s2);
s3 := s1[1] + s1[2] + s2[1] + s2[2];
writeln('Novaja stroka: ', s3);
end.
Довгий час знання, яких набувала людина протягом життя, передавались усно від покоління до покоління, що не забезпечувало безперервного поповнення бази знань людства в цілому. Безперервний процес збереження інформації забезпечила писемність, яка дозволяла накопичувати інформацію.
Спочатку люди викарбовували написи на камінні, потім видавлювали гострими паличками на глиняних дощечках. Писали паличками на папірусі, пензликами на шовку і перами на папері. Гусяче перо змінили ручки з металевим пером, а їх – графітові олівці, авторучки, а згодом друкарські машини.
Проте в роботі з текстами залишалося незмінним головне: щоб внести зміни в текст, його потрібно було щоразу переписувати або передруковувати. І лише застосування комп'ютерів і спеціальних програм принципово змінило технологію роботи з текстом. У чому ж полягають переваги у використанні ПК для обробки текстів?
Для роботи з текстом на ПК використовують: текстові редактори, текстові процесори та видавничі системи. У загальному їх називають системами обробки текстів – програми, які призначені для створення, редагування й друку текстових документів.
Текстовий редактор – це програма, що дозволяє вводити, редагувати, форматувати та зберігати текст.
Текстовий процесор – це програма, що дозволяє вводити, редагувати й форматувати текст, вставляти малюнки й таблиці, перевіряти правопис, складати зміст, виконувати перенос слів та багато інших складних операцій.
Настільна видавнича система (НВС) – це програма, за до якої можна створювати високоякісні оригінал-макети, що містять текст і графічні зображення для тиражування в друкарні.
Наприклад:
• текстові редактори (Multi-Edit, Блокнот, WordPad, Твір, Лексикон);
• текстові процесори (Microsoft Word, Word Prefect, OpenOffice, Word-Star);
• настільні видавничі системи (Adobe PageMaker, Corel Ventura, Publisher, QuarkXPress).
Вивчаючи в 9-му класі роботу з текстовим процесором Word 2003, ви вже навчилися створювати текстові документи, редагувати і форматувати текст, вставляти в документ і форматувати векторні графічні зображення. Однак користувач майже завжди передбачає, що створений ним документ буде надрукований. Тому важливо оформити документ так, щоб він гарно виглядав не тільки на екрані, але й на аркуші паперу.
Объяснение: