В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
яна1762
яна1762
17.09.2022 05:10 •  Информатика

Напишите программу для следующих задач
1) в последовательности целых чисел определить количество нечётных чисел, кратных 3. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести два числа: длину последовательности (завершающий 0 не учитывается) и количество нечётных чисел, кратных 3.
2) В последовательности целых чисел определить их количество и сумму чётных чисел. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести два числа: длину последовательности и сумму чётных чисел.
3) В последовательности целых чисел определить их количество и подсчитывает сумму положительных чётных чисел, не превосходящих 256. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести два числа: длину последовательности и сумму положительных чётных чисел, не превосходящих 256
4) В последовательности натуральных чисел определяет количество всех чётных чисел, кратных 5. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа должна вывести одно число: количество всех чётных чисел, кратных 5.
5) В последовательности натуральных чисел определяет количество всех чётных чисел, кратных 9. Количество введённых чисел неизвестно, но после ввода 0 ввод чисел заканчивается. Программа, должна вывести одно число: количество всех чётных чисел, кратных 9.

Показать ответ
Ответ:
Student9923
Student9923
19.12.2020 02:09
Class OftenChar{
 public static void main(String args[]){
  java.util.Scanner in = new java.util.Scanner(System.in);
  String string = in.nextLine(); char chars[] = new char[4];
  chars[0] = in.nextLine().charAt(0); chars[2] = in.nextLine().charAt(0);
  for(int sChar = 0; sChar<string.length(); sChar++)
   if(string.charAt(sChar)==chars[0])chars[1]++;
   else if(string.charAt(sChar)==chars[2])chars[3]++;
  System.out.print("\n"+(chars[1]==chars[3]?chars[0]+""+chars[2]:chars[1]>chars[3]?chars[0]:chars[2]));
 }
}
0,0(0 оценок)
Ответ:
avomilag95
avomilag95
11.01.2023 07:35
Program pr;
uses crt;

var a,b:real;

Begin
writeln('Введите первое число');
readln(a);
writeln('Введите второе число');
readln(b);

if (a<0) and (b<0)   
    then     
       Begin       
            a:=a+2;
            b:=b+2; 
             writeln('a = ',a); 
             writeln('b = ',b); 
        end
else 
      if (a>0) and (b<0)     
        then       
           writeln('a*b = ',a*b)
      else 
           if (a<0) and (b>0)     
                then        
                   writeln('b-a = ', b-a)

           else  writeln('Ни одно условие не выполняется');

readln;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота