В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
VasyaKotikSnake
VasyaKotikSnake
17.10.2020 03:31 •  Информатика

Напишите программу для решения следующей задачи. На контрольной работе по алгебре ученикам 9 класса было предложено 10 примеров. Неудовлетворительная оценка выставляется, если правильно решено менее половины примеров. Сколько неудовлетворительных оценок было получено учениками? Если хотя бы один из учеников правильно решил все задачи, выведите YES, иначе выведите NO. Программа получает на вход количество учеников в классе N (1 ≤ N ≤ 30), затем для каждого ученика вводится количество правильно решённых примеров.ЯЗЫК С+++

Показать ответ
Ответ:
карольчик1
карольчик1
15.01.2021 16:33

var a,b,c,d,e:integer;

begin

d:=1;

e:=0;

writeln('введите количество учеников');

readln(a);

for b:=1 to a do begin

writeln('введите количество правильных ответов для ',d,' ученика' );

readln(c);

while (c>10) or (c<0) do begin

writeln('вы ввели неверное число, попробуйте снова');

readln(c);

end;

if c = 10 then e:=e+1;

d:=d+1;

end;

if (e>=1) then writeln('yes ')

else writeln('no');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота