В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Audika
Audika
07.11.2021 02:08 •  Информатика

Напишите программу для расчета итоговой суммы награды игрока. Алгоритм должен отвечать следующим условиям:  Бонус начисляется только если игрок получит максимум за прохождение уровня.  Если игрок получил за уровень меньше максимума, то бонус он не получает. Размер получаемого бонуса определяется согласно нижеприведенной таблице. 1 уровень - x0,5 от награды за текущий уровень 2 уровень - х1 от награды за текущий уровень 3 уровень - х1,5 от награды за текущий уровень 4 уровень - х2 от награды за текущий уровень 5 уровень - x2,5 от награды за текущий уровень 6 уровень - x3 от награды за текущий уровень 7 уровень - x3,5 от награды за текущий уровень  

Напиши программу для расчета бонуса на языке программирования Python.

Показать ответ
Ответ:
alexandra2981278247
alexandra2981278247
23.09.2022 15:33
Const n=20;
type omas=array[1..n] of integer;
Procedure Del (var z:omas; k:byte); 
var i:byte; 
begin 
for i:=k to n-1 do z[i]:=z[i+1]; 
z[n]:=0; 
end; 
var a:omas; i,b:integer;
begin
Randomize;
for i:=1 to n do
 begin
 a[i]:=random(20);
 write(a[i]:4);
 end;
writeln;
b:=6;
i:=1;
while (i<=n)and(a[i]<>b) do i:=i+1;
if i<=n then
  begin
  Del(a,i);
 writeln('Размерность массива = ',n-1);
 for i:=1 to n-1 do write(a[i]:4);
 writeln;
 end  else writeln('Массив не изменился');
end.
Пример:
  12  13   6   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
Размерность массива = 19
  12  13   7  17   1  18  17   3   2  12   3  16   6   7  13   0   2   5  18
0,0(0 оценок)
Ответ:
nekiti444
nekiti444
19.05.2020 22:24
Чтобы контрольная работа получила высший , необходимо как следует постараться: изучить теорию написания контрольных работ, посмотреть методички и гост, составить план и многое другое. как видите, решение контрольной работы не такая уж и простая . но продвинутые студенты, которые знают цену своему времени и силам, заказывают решение контрольных работ у нас. это быстро, качественно и доступно каждому. мы не пользуемся услугами посредников, чему цены на наши услуги значительно ниже, а работа выполняется быстрее. образец плана контрольной работы конечно, всегда будут студенты, которые любят самостоятельно писать контрольные работы. им мы тоже стараемся всеми силами. поэтому мы подобрали несколько качественных примеров плана контрольных работ, которые демонстрирует практически идеальное выполнение плана. опираясь на эти примеры, не забывайте и о теории. план контрольной работы должен быть детально проработан. в нем вы должны указать, сколько точно будет разделов, глав и параграфов. кроме того, им нужно дать названия, которые будут уникальными (т.е. не повторяются в тексте работы больше одного раза). план также определить, какой объем займет ваша контрольная работа. распределяя главы, продумывайте, что вы будете в них писать, какая информация вам для этого понадобится, что вам для этого не хватает. если вы будете четко следовать нашим советам, вы без труда сможете самостоятельно написать план к любой контрольной работе. взято со страницы:
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота