Напишите программу для андроида на языке Java которая будет генерировать случайное квадратное уравнение а после выводить на экран для того чтобы человек мог вписать ответ и программа сказала бы правильно решено уравнение или нет, в случае неправильно решенного уравнения программа генерировала новое уравнение до того момента пока человек не решит его правильно после этого программа завершалась.
Табличный процессор (ТП) — это прикладная программа, предназначенная для организации табличных вычислений на компьютере.Вычислительная таблица, которая создается с ТП, называется электронной таблицей.Первый табличный процессор был создан в 1979 году, предназначался для компьютеров типа Apple II и назывался VisiCalc. В 1982 году появился табличный процессор Lotus 1-2-3, предназначенный для IBM PC. Lotus объединил в себе возможности электронных таблиц, деловую графику и некоторые функции реляционной СУБД. Практически все последующие табличные процессоры (Multiplan, QuattroPro, SuperCalc и другие) поддерживали эти три функции. Одним из самых популярных табличных процессоров сегодня является MS Excel, входящий в состав пакета Microsoft Office. Кратко повторим основные понятия, связанные с электронными таблицами.
Язык: Java
1.
public class Sum {
public static void main(String args[]) {
//n — первая граница чисел, sum — сумма чисел; i — складыватель числа n — на саму себя
int n = 0, sum, i = 0;
//i — стремится к 50, каждый раз увеличиваясь на 1 — но одновременно давая своё значение переменной n.
for(; i <= 50; i++) {
n += i;
}
System.out.println(n);
}
}
Output: 1275.
2.
public class Sum1 {
public static void main(String args[]) {
//Одни и те же переменные, но только i — должен быть на 2 больше n, так как в цикле for — подчёт начинается сразу с заранее заданным значением.
int n = 112, sum, i = 114;
//Кстати заметили, что n — начинается не с 111? Потому что в цикле, подчёт, и складывание на 2 — начнётся именно с 111, и в итоге все цифры будут нечётными, поэтому первая цифра должна быть чётной, и больше 111, то есть — 112.
for(; i <= 200; i+=2) {
n += i;
}
System.out.println(n);
}
}
Output: 7020.
3.
Ты имеешь ввиду — вывести в противоном случае все числа — в модулях? Или поменять их знаки, с отрицательного на положительного, и наоборот?
//Создание класса Scanner, для последующих вводов пользователя
import java.util.Scanner;
public class Sum {
public static void main(String args[]) {
int a, b, c;
//Для возможности ввода пользователя, создадим объект "input" класса Scanner
Scanner input = new Scanner(System.in);
//Ввод пользователя
System.out.println("Enter the first number: ");
a = input.nextInt();
System.out.println("\n Enter the second number: ");
b = input.nextInt();
System.out.println("\n Enter the third number: ");
c = input.nextInt();
//Условия, заданные в задаче. Знак "&&" означает "также"
if(c<=b && b<=a) {
a = a*2;
b = b*2;
c = c*2;
}
//Math.abs() — метод, который возвращает абсолютное значение числа, то есть выводит в модуль.
else {
System.out.println("\nThe first number: " + Math.abs(a) + "\nThe second number: " + Math.abs(b) + "\nThe third number: " + Math.abs(c));
}
}
}
4.
import java.util.Scanner;
public class Sum {
public static void main(String args[]) {
//Объявленя двух чисел
int a, b;
Scanner input = new Scanner(System.in);
//Ввод пользователя
System.out.println("The first nubmer: ");
a = input.nextInt();
System.out.println("\nThe second number: ");
b = input.nextInt();
if(a>b) {
System.out.println("\n" + a);
}
else {
System.out.println("\n" + a + "; " + b);
}
}
}