Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
nastya2737
06.09.2022 21:06 •
Информатика
Напишите, , программу . дано: х, у, z найти: вывести на экран только положительные числа и найти сумму отрицательных
Показать ответ
Ответ:
ПрофессорЧерепашка
07.10.2020 20:14
Var
sum, a,b,c:real;
begin
Readln(a,b,c);
if a > 0 then Write(a, ' ') else sum:= sum + a;
if b > 0 then Write(b, ' ') else sum:= sum + b;
if c > 0 then Write(c, ' ') else sum:= sum + c;
Writeln;
Writeln('Cумма отрицательных эл-в = ', sum);
end.
Пример:
-5 2 1
2 1
Cумма отрицательных эл-в = -5
0,0
(0 оценок)
Популярные вопросы: Информатика
milenmuradyan
25.09.2020 14:12
64- цветной рисунок содержит 20мбайт информации . из какого количества точек он состоит...
STALKER147
04.03.2021 17:34
1) Чему будет равна переменная «c» после выполнения этой программы: a= 36; b = 7; b = a // b + 2*b; c = a % b - a; 2) Чему будет равна переменная «c» после выполнения...
seniorkovalyov
24.05.2021 00:46
Что такое интерфейс текстового редактора Ms Word...
aselb84
07.08.2021 01:15
Сколько клеток закрасит Робот, выполнив такой алгоритм? Стартовая позиция Робота на рисунке обозначена буквой Р. нц пока справа свободно вправо закрасить вправокц...
Anasteija
29.05.2020 08:59
Система команд исполнителя Раздвоителя содержит две команды 1. вычти 1 2. раздели на 2 Какое число получит исполнитель Раздвоитель, начав с числа N = 14 и выполнив...
zaaz123
15.03.2020 20:22
Дано масив А[15]. Запишіть оператори для реалізації завдань: а) ввести з клавіатури значення елементів масиву;б) знайти добуток елементів масиву;в) знайти мінімальний...
ali0002
11.03.2020 19:37
1. Використовуючи встановлене IDLE (Python) напишіть програму для обчислення свого віку (роки) в секундах. 2. В інтерактивному режимі використайте Python для виведення...
vika78678
23.05.2020 18:38
Напишите программу, которая в последовательности натуральных чисел определяет сумму двухзначных чисел, кратных 5. Программа получает на вход натуральные числа,количество...
Yana12ost
10.09.2021 03:33
- У середовищі програмування Pycharm створіть проект Швидкий пошук Для знаходження у списку з 10 дійсних чисел елемента, що відповідає заданій умові. выручайте . Скиньте...
nastya368421678
03.01.2022 23:23
Когда невозможно установить связь таблиц?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
sum, a,b,c:real;
begin
Readln(a,b,c);
if a > 0 then Write(a, ' ') else sum:= sum + a;
if b > 0 then Write(b, ' ') else sum:= sum + b;
if c > 0 then Write(c, ' ') else sum:= sum + c;
Writeln;
Writeln('Cумма отрицательных эл-в = ', sum);
end.
Пример:
-5 2 1
2 1
Cумма отрицательных эл-в = -5