В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
gagammil
gagammil
06.11.2020 13:43 •  Информатика

Напишите программу )) дан массив действительных чисел.среди них есть равные .найти первый максимальный элемент массива и заменить его нулём

Показать ответ
Ответ:
student2544
student2544
24.05.2020 06:53

Program num1;
Uses crt;
Var x:array[1..10] of real;
max:real;
i : integer;
Begin
clrscr;
for i:=1 to 10 do
begin
write('x[',i,']=');readln(x[i])
end;
max:=x[1];
for i:=1 to 10 do
if x[i]>=max then max:=x[i];
Writeln('Max=',max:3:1);
for i:=1 to 10 do
if x[i]=max then begin x[i]:=0;break end;
for i:=1 to 10 do write(' *',x[i]:3:1,'* ');
End.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота