В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
наташа978
наташа978
31.05.2023 06:15 •  Информатика

напишите программу 1) Последовательность изменяется по закону 2,10,18... Сколько элементов последовательности надо взять, чтобы их сумма была больше 100 2) С клавиатуры вводится 20 чисел. Определите произведение этих чисел, количество положительных, сумму отрицательных элементов заранее

Показать ответ
Ответ:
MrsKamYl
MrsKamYl
14.01.2022 06:00

Решение на паскале.

Объяснение:

Первая задача:

var summa, kolichestvo : integer;

 begin

   summa := 2;

   while summa <= 100 do

   begin

     summa := summa + 8;

     kolichestvo := kolichestvo + 1;

   end;

   writeln('Количество = ', kolichestvo);

 end.

Вторая задача:

var a : array[1..20] of integer;

   kolpol, sumot, i : integer;

begin

 for i:=1 to 20 do

   Read(a[i]);

 for i := 1 to 20 do

   if a[i] >= 0 then

     kolpol := kolpol +1

   else

     sumot := sumot + a[i];

 writeln('Количество положительных = ', kolpol);

 writeln('Сумма отрицательных = ', sumot);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота