Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
аааликкк43527
06.09.2021 10:01 •
Информатика
Напишите процедуру в паскале, которая принимает параметр – натуральное число n – и выводит на экран линию из n символов '–'.
Показать ответ
Ответ:
SanchesMaster
04.10.2020 02:43
Var
n: integer;
procedure WriteNSymbols(n: integer; c: char);
var
i: integer;
begin
for i := 1 to n do
write(c);
end;
begin
readln(n);
WriteNSymbols(n, '-');
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
ksenia1unicorn
05.07.2022 13:40
Решить логично задачу с таблицы . Дорога расход в три стороны домой в тупик к змею Горыныча 1.путь 1дорога в тупик 2.путь 2путь дорога в тупик 3.дорога в пещеру. Все знают...
Kobrasmary
05.06.2020 23:22
Написать программу (в Pascal) для нахождения значении функции Y = R * SIN (X) + 24 * P на промежутке [A, B] во всех целых числах. Считать : значение А из файла prom1.txt...
Dabbnathion
25.03.2022 17:41
Что называется основанием системы счисления? выберите один ответ: a. сумма всех цифр системы счисленияb. арифметическая основа эвмc. отношение значений единиц соседних разрядовd....
ЛюБИмИЦа55
10.11.2022 19:11
Автомат получает на вход трёхзначное число. по этому числу строится новое число по следующим правилам. 1. складываются первая и вторая, а также вторая и третья цифры исходного...
supermosyagina
09.02.2022 11:40
Продолжить ряд десятичных чисел: 22 44 66 88...
46hitman46
09.02.2022 11:40
Укажите наименьшее четырёхзначное восьмеричное число, двоичная запись которого содержит ровно 4 нуля. в ответе запишите только само восьмеричное число, основание системы...
lubvic77
09.02.2022 11:40
Чертежнику был дан для исполнения следующий алгоритм: повтори 3 раз сместиться на (-2.-3) сместиться на (3,2) и на (-4,0) конец на какую одну команду модно заменить этот...
elen72
30.08.2021 12:01
Выпиши все числа от 13 до 20 и найди их сумму,используя алгоритм гаусса. умоляю надо (...
nosia
14.10.2021 13:28
Сколько единиц в двоичной записи десятичного числа 1020...
juliyamacko99
18.04.2023 02:39
Найти значение ниже логических выражений: (a z) or (z 2) or (a ≠ 5) при a) a = 5, z = -4; б) a = -5,z = 0;...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
n: integer;
procedure WriteNSymbols(n: integer; c: char);
var
i: integer;
begin
for i := 1 to n do
write(c);
end;
begin
readln(n);
WriteNSymbols(n, '-');
end.