Напишите (на языке Pascal) программу, которая переставляет строки матрицы так, чтобы значения в столбце K шли в порядке убывания. Строки, у которых значения в столбце K равны, должны быть выведены в том же порядке, в котором они стояли в исходной матрице. Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами. В последней строке вводится номер столбца K .
Выходные данные
Программа должна вывести получившуюся матрицу, в которой строки переставлены так, чтобы значения в столбце K шли в порядке убывания.
Им можно открыть и посмотреть текстовое представление любого файла, хотя большие файлы он не откроет (зависнет или упадет) и может иметь проблемы с кодировками.
Имеет простейшие функции типа поиск, замена, переход. А так же открыть и сохранить файл.
Если часто приходится иметь дело с текстовыми файлами предназначеными в первую очередь для чтенье компьютером типа программных кодов, скриптов и тд, то рекомендуется использовать специализированные блокноты типа Notepad++, Sublime Text, Vim, Akelpad и тд
MSO Word предназначен для создания, просмотра, редактирования текстовых документов (не просто текстовых файлов) предназначеных в первую очередь для просмотра людьми. Потому очень много уделяется внимания форматированию текста, можно добавлять всякие рисунки, таблички и прочее и прочее
Можно редактировать и простые текстовые файлы, но это не удобно
const n=10;
var a:array[1..n+1] of integer;
p,i:integer;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
begin
a[i]:=random(21);
write(a[i]:4);
end;
writeln;
write('p = '); readln(p);
a[n+1]:=p;
i:=1;
while a[i]<>p do i:=i+1;
if i<=n
then writeln('Искомый элемент найден, его номер = ',i)
else writeln('Искомый элемент не найден');
end.
Пример 1:
Исходный массив:
7 17 16 13 0 1 19 20 12 5
p = 13
Искомый элемент найден, его номер = 4
Пример 2:
Исходный массив:
20 4 5 12 14 10 11 16 18 20
p = 15
Искомый элемент не найден