Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
kseniyarigil
04.10.2022 20:24 •
Информатика
Напишите на языке c++! создать массив размером 10! заполнить его рандомными числами! и заменить все четные числа в массиве на цифру -9;
Показать ответ
Ответ:
Неизвестная002
05.10.2020 14:17
#include <iostream>
#include <cstdlib>
#include <ctime>
using namespace std;
int main()
{
int ranmas[10] = {};
srand(time(NULL));
cout<<"original massiv:"<<endl;
for (int i = 0; i < 10; i++)
{
ranmas[i] =rand() % 41 - 20;
cout << ranmas[i]<<endl;
}
cout<<"final massiv:"<<endl;
for(int i=0;i<10;i++)
{
if (ranmas[i] % 2==0){ ranmas[i]=-9;}
}
for (int i = 0; i < 10; i++) { cout << ranmas[i]<<endl; }
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
KekCheburashka
29.11.2022 16:52
Скачал приложение энвидия ртх войс теперь клава не регулирует громкость (клавиатура corsair K74)...
vladzaorozhniy
12.01.2020 13:11
Уровень c. напишите программу, которая заполняет массив из n = 10 случайными числами в диапазоне [10,50], выводит его на экран, а затем выполняет реверс отдельно первой и второй половин...
uzinalizs
24.01.2021 08:48
Автомобилиста: известны скорости автомобилей, едущих навстречу друг-другу из пунктов а и б. найти время через которое они встретятся....
ka931
10.06.2020 09:42
Написати твір роздум чому деякі люди самотні...
олжас200
10.06.2020 09:42
Специальный и общий вопрос 1. it’s very late already 2.they are quarreling 3.they have already had lunch 4.she will join our party a bit later...
Эммикэт
10.06.2020 09:42
Вавтобус вмещается 40 пассажиров. из начального пункта выехало 8человек. на каждой остановке из автобуса выходило в три раза меньше пассажиров,чем заходило. через несколько остановок...
Dashyliavvv
10.06.2020 09:42
Что было изображено на щиту ахилла?...
проблемка4
10.06.2020 09:42
Найдите меньшее основание равнобедренной трапеции,если ее большее основание равно 22 см, боковая сторона 10 см, а один из углов равен 60...
ladakorobova
10.06.2020 09:42
Автомобиль ехал по шоссе со скоростью 100 км/ч 3 часа, затем свернул на грунтовую дорогу и 2 часа ехал со скоростью 60 км/ч. определите среднюю скорость автомобиля....
Uoywex
10.06.2020 09:42
Завтра олимпиада,кратко напишите россии с древнейших времён до xvi века...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include <cstdlib>
#include <ctime>
using namespace std;
int main()
{
int ranmas[10] = {};
srand(time(NULL));
cout<<"original massiv:"<<endl;
for (int i = 0; i < 10; i++)
{
ranmas[i] =rand() % 41 - 20;
cout << ranmas[i]<<endl;
}
cout<<"final massiv:"<<endl;
for(int i=0;i<10;i++)
{
if (ranmas[i] % 2==0){ ranmas[i]=-9;}
}
for (int i = 0; i < 10; i++) { cout << ranmas[i]<<endl; }
return 0;
}