В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
dianahaliullina1
dianahaliullina1
08.03.2021 11:52 •  Информатика

напишите на каком языке программировали: B. Укладка плитки
Ограничение времени 1 секунда
Ограничение памяти 64.0 Мб
Ввод стандартный ввод или input.txt
Вывод стандартный вывод или output.txt
Мэр нашего города хочет уложить максимум плит размером 2 × 1 клеток без деления их пополам на площади размером K × N клеток. Требуется уложить максимум плит при условии, что:

Можно поворачивать плиты
Плиты не пересекаются
Все плиты лежат внутри площади, касание краёв допускается.
Найдите максимум плит, которые можно уложить при данных условиях.

Формат ввода
В единственной строке записано два целых числа K и N — размеры площади в клетках (1 ≤ K ≤ N ≤ 16)

Формат вывода
Выведите одно число — максимальное количество плит, которые можно уложить

Пример 1
Ввод Вывод
2 4
4
Пример 2
Ввод Вывод
3 3
4

Показать ответ
Ответ:
kirkanobotan
kirkanobotan
09.09.2020 21:55

Объяснение:Временные значения денег

В зависимости от точки зрения, номинальное значение денег может быть различным. Ключевое понятие здесь — временное значение денег. Вычисления, производимые над денежными суммами, могут производиться в настоящем или в будущем. Выбор типа вычислений основывается на

том, что сумма денег увеличивается, поскольку постоянно поступают начисления по процентам. Другими словами, вложив

один рубль сегодня, завтра вы получите больше.

Например, предположим, что богатенький заокеанский

дядюшка решил подарить вам деньги, причем нужно выбрать

один из вариантов.

Получить 80 000 руб. сегодня.

Получить 95 000 руб. через год.

Получить 120 000 руб. через пять лет.

Получать 1 500 руб. каждый месяц на протя

0,0(0 оценок)
Ответ:
Darvin2004
Darvin2004
27.04.2021 17:40
#include "stdafx.h"
#include <stdio.h>
#include <windows.h>

int main()  
  {
    SetConsoleCP(1251);      
    SetConsoleOutputCP(1251);  
 
int const n=3;
int mas[n][n];
int sum1, sum2;
bool magik;

for (int i=0; i<n; i++)
    for (int j=0; j<n; j++)
         {
           printf("mas[%d][%d] = ", i+1, j+1);
           scanf("%d",&mas[ i ][ j ]);
         }

printf("\nВведенная матрица:\n");
     for (int i=0; i<n; i++)
        {
             for (int j=0; j<n; j++)
                       {
                          printf("%d  ",mas[ i ][ j ]);
                       }
             printf("\n");
         }

sum1=0;
sum2=0;

for (int i = 0; i<n; i++)
     {
            sum1 += mas[ i ][ i ];
            sum2 += mas[ i ][ n-1-i ];
      }

printf("Сумма главной диагонали = %d\n", sum1);
printf("Сумма побочной диагонали = %d\n", sum2);

magik = true;
for (int i=0; i<n; i++)
    {
        if (sum1==sum2)
             {
                 sum2=0;
                 for (int j=0; j<n; j++)
                    {
                        sum2 += mas[ i ][ j ];
                     }
              } else  { magik=false; break; }
     }

if (magik==true)
     {
           for (int i=0; i<n; i++)    
               {
                   if (sum1==sum2)
                        {
                           sum2=0;
                           for (int j=0; j<n; j++)
                               {
                                   sum2 += mas[ j ][ i ];
                               }
                         }
                        else  { magik=false; break; }
                 }
       }

if (magik==true)
    printf("\nМатрица является магическим квадратом\n");  
else
    printf("\nМатрица не является магическим квадратом\n");

system("pause");
return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота