В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Kruzhilina242003
Kruzhilina242003
14.06.2021 05:24 •  Информатика

Напишите мне данное от program до end. (тема "циклы"- pascal abc) написать программу, которая вычисляет сумму первых в членов ряда: 1,3,5, количество суммированных членов ряда задаётся во время работы программы. ниже примерно рекомендуемый вид экрана во время работы программы. вычисление частичной суммы ряда: 1,3,5, введите количество суммированных членов ряда -> 1-5 сумма первых 15 членов ряда равна 330.

Показать ответ
Ответ:
redridinghood1
redridinghood1
29.07.2020 11:53
Program zhn;
var
  i,n,sum:integer;
begin
  writeln('Вчисление суммы членов последовательности: 1,3,5,7...');
  write('Введите количество членов для сложения:');
  readln(n);
  for i:=1 to n*2 do begin
    if i mod 2 <> 0 then sum:=sum+i; //Проверяем что бы число было нечетным
  end;
  writeln('Сумма ',n,' членов прогресии = ',sum);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота