В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
esbolat2000
esbolat2000
16.10.2021 03:15 •  Информатика

Напишите математическое выражение на языке Питон
Подпись отсутствует


Напишите математическое выражение на языке Питон Подпись отсутствует

Показать ответ
Ответ:
sonya408
sonya408
23.01.2022 01:29
Написал на C# но в принципе код  очень простой поэтому сможешь переписать на любой язык)

Console.WriteLine("Введите А");           
int a = Convert.ToInt16(Console.ReadLine());           
if (a >0)
{ Console.WriteLine("---------------------------");
 Console.WriteLine("Число "+a+" положительное"); }           
 if (a < 0) { Console.WriteLine("---------------------------");
Console.WriteLine("Число " + a + " отрицательное"); }           
 if (a == 0) { Console.WriteLine("---------------------------");
Console.WriteLine("Вы ввели 0"); }                          
  Console.ReadLine();
Составить алгоритм и написать программу. пользователь вводит число а, программа определяет положител
Составить алгоритм и написать программу. пользователь вводит число а, программа определяет положител
0,0(0 оценок)
Ответ:
Димасик2017
Димасик2017
29.10.2020 04:01
Program Table;
uses math; //подключаем математический модуль, возможно с модулем я ошибся
var  // объявляем локальные переменные для программы
    a , b, h : Real; //указывает дробный тип числа

function calculate_f( x: Real) : Real; //объявляем функцию в теле программы
begin
    calculate_f := 1/2*sin(x/4+1) ;   //записываем результат вычисления в функцию
end;

Begin
    a := -0.99; //определяем
    b :=  50.0;  //вводные
    h := 0.1; //значения

    while a < b do begin //пока "a" меньше "b"
        writeln("F(", a, ') = ', calculate_f(a)); //выводим результат вычислений в строку
        a := a + h; //прибавляем шаг "h"
    end;
end.

Я могу и ошибиться, потому что писал на Паскале оочень давно :D
Поэтому Вам прийдется поправить некоторые ошибки в коде.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота