Напишите эффективную программу, которая по двум данным натуральным числам m и n, не превосходящим 30000, подсчитывает количество натуральных чисел с последней цифрой 0 на отрезке [m,n] (включая концы отрезка) программа получает на вход два натуральных числа m и n, при этом гарантируется, что 1≤m≤n≤30000. программа должна вывести одно число: количество натуральных чисел с последней цифрой 0 на отрезке [m,n].
Program Pr1;
uses crt;
const t=30000;
var mas:array[1..t] of integer;
i,n,m,l:integer;
begin
clrscr;
for i:=1 to t do mas[i]:=i;
writeln('введите n и m');
readln(n,m);
l:=0;
for i:=n to m do if mas[i] mod 10=0 then l:=l+1;
writeln(l);
end.