В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ruzali4
ruzali4
13.09.2021 14:48 •  Информатика

Напишите алгоритм в виде программы на паскале напишите ая алгоритм вычисления у по формуле у=(1-х²+5х^4)², где х- заданное число. учтите следующие ограничения: 1) в арифмитических выражения можно использовать только операции сложения, вычитания и умножения. 2) каждое выражение может содержать только одну арифметическую операцию. выполните трассировку алгоритма при х= 2. добавлю за ответ без

Показать ответ
Ответ:
alesa6002
alesa6002
03.10.2020 11:34
Var x,x2,x4,y:real;
begin
write('x = '); readln(x);
x2:=x*x;
x4:=x2*x2;
x4:=5*x4;
y:=1-x2;
y:=y+x4;
y:=y*y;
writeln('y = ',y);
end.

Пример:
x = 2
y = 5929

Трассировка:
x=2
x2=2*2=4
x4=4*4=16
x4=5*16=80
y=1-4=-3
y=-3+80=77
y=77*77=5929
0,0(0 оценок)
Ответ:
хабиб36
хабиб36
03.10.2020 11:34
Var x,y:real;
begin
write('Введи x = ');readln(x);
y:=(1-x*x+5*x*x*x*x)*(1-x*x+5*x*x*x*x);
writeln('y = ',y);
end. 
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота