Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
DianaSmile111
17.07.2020 21:58 •
Информатика
Напиши программу, которая выводит сумму n чисел, введенных пользователем. число n должно так же определяться пользователем. язык с#
Показать ответ
Ответ:
ziketeam123
01.09.2020 20:32
Using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace 1
{
class Program
{
static void Main(string[] args)
{
bool Mistake = false;
int N = 0;
do
{
Console.Write("Введите количество слагаемых: ");
try
{
N = Convert.ToInt32(Console.ReadLine());
Mistake = false;
}
catch (FormatException)
{
Mistake = true;
Console.Clear();
Console.WriteLine("Неверный формат ввода! Повторите попытку!");
Console.WriteLine();
}
}
while (Mistake == true);
Sum(N);
}
static void Sum(int N)
{
double[] Elements = new double[N];
double Result = 0;
for (int i = 0; i < N; i++)
{
Console.WriteLine();
Console.Write("Введите " + (i + 1) + " число: ");
try
{
Elements[i] = Convert.ToDouble(Console.ReadLine());
}
catch (FormatException)
{
Console.WriteLine("Неверный формат ввода!");
}
}
for (int j = 0; j < N; j++)
{
Result += Elements[j];
}
Console.WriteLine();
Console.Write("Сумма = " + Result);
Console.ReadKey();
}
}
}
0,0
(0 оценок)
Популярные вопросы: Информатика
unknown2015
21.07.2021 07:11
Задание 2. Используя приложение Калькулятор узнаете, сколько времени между датами 17 марта 1974 года по сегодняшний день. Промежуток времени укажите в днях, неделях, месяцах...
AnnaVlasova09
02.06.2023 23:27
Определи заполнения массива. Выбери, какие элементы массива подходят....
gulchik1979g
20.01.2021 13:55
Сколько различных буквенных сочетаний (в буквенных сочетаниях две буквы) можно составить из букв Q, W, E, R, T? Буквы в буквенных сочетаниях не повторяются....
mashakostyuk8
09.10.2021 03:24
Елемент керування для пересилання листа іншому адресату це - ......
seremet1984
03.12.2021 23:20
у папці зберігаються електронні повідомлення, які надійшли на адресу скриньки від адресатів....
11Doctor
03.10.2022 21:13
Как из утвердительных предложений делать вопросительные и отрицательные?...
arlanout
03.10.2022 21:13
Какая из перечисленных норм имеет большую юридическую силу: а)указ президента рф б)постановление правительства в)постановление конституционного суда г)федеральный закон...
Karina25052005
03.10.2022 21:13
№1. вычислите (36⁷ × 49² × 8 × 15⁶ )÷(27 × 18⁸ × 10⁷ × 14³) а)8,4 б)2,8 в)1,4 г)2,1 №2.какие уравнения не имеют действительных корней? а)9x²-42x + 50 = 0 б)(2x - 4)(2x+4)+16...
qamqsmbfhfuc
03.10.2022 21:13
Перевести в косвенную речь. have you called your mother lately? ,he asked me. he asked me if i had called my mother lately let s text each other about it later? ,he said. he...
haha1
03.10.2022 21:13
Втреугольнике abc : ac=bc , угол c = 120 , ab=18. найдите высоту ah ?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
namespace 1
{
class Program
{
static void Main(string[] args)
{
bool Mistake = false;
int N = 0;
do
{
Console.Write("Введите количество слагаемых: ");
try
{
N = Convert.ToInt32(Console.ReadLine());
Mistake = false;
}
catch (FormatException)
{
Mistake = true;
Console.Clear();
Console.WriteLine("Неверный формат ввода! Повторите попытку!");
Console.WriteLine();
}
}
while (Mistake == true);
Sum(N);
}
static void Sum(int N)
{
double[] Elements = new double[N];
double Result = 0;
for (int i = 0; i < N; i++)
{
Console.WriteLine();
Console.Write("Введите " + (i + 1) + " число: ");
try
{
Elements[i] = Convert.ToDouble(Console.ReadLine());
}
catch (FormatException)
{
Console.WriteLine("Неверный формат ввода!");
}
}
for (int j = 0; j < N; j++)
{
Result += Elements[j];
}
Console.WriteLine();
Console.Write("Сумма = " + Result);
Console.ReadKey();
}
}
}