В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия

Написать в паскале найти минимальное из чётных элементов массива пяти целых чисел. по фигурному катанию n судей выставляют оценки. наибольшая и наименьшая отбрасываются, а по остальным выставляется средний . напишите программу, вычисляющую среднюю оценку и выдайте номер судей, которые поставилинаибольшую и наименьшую оценки.

Показать ответ
Ответ:
Жека331211
Жека331211
29.05.2020 10:19

2)

uses crt;

const n=random(50);

var a:array[1..n]of integer;

i,min,max,s,k:integer;

begin

clrscr;min:=11;writeln('оценки ',n+1,' судей');

for i:=1 to n do

begin

a[i]:=random(10);

write(a[i],' ');

if a[i]> max then max:=a[i];

if a[i]<min then min:=a[i];

end;

for i:=1 to n do

begin

if (a[i]=min)or(a[i]=max) then begin write(i,' судья поставил минимальный или максимальный балл');writeln;end;

if (a[i]<>min)and(a[i]<>max) then begin s:=s+a[i];k:=k+1;end;

end;

writeln('среднее значение оценок судей ',(s/k):1:1);

end.

1)Uses crt;

const n=5;

Var a:array[1..n]of integer;

   i,min,km:integer;

begin clrscr; randomize;

 for i:=1 to n do

 begin

   a[i]:=Random(100);

   write(a[i],' ');

 end;

 writeln;

 min:=a[1];

 km:=1;

 for i:=2 to n do if a[i]<min then

 begin

   min:=a[i];

   km:=i;

 end;

 writeln('Mimimalnoe chislo a[',km,']=',min);

 min:=100;

 km:=1;

 for i:=2 to n do if (a[i]<min)and(a[i]mod 2=0) then

 begin

   min:=a[i];

   km:=i;

 end;

 writeln('Naimenshee chetnoe cislo a[',km,']=',min);

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота