В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
anjela2288
anjela2288
26.05.2022 10:19 •  Информатика

Написать в pascal abc. задано трехзначное восьмеричное (двоичное) число. составить программу для перевода этого числа в десятичную систему счисления.

Показать ответ
Ответ:
catcot1
catcot1
20.09.2022 23:39

1.Постановка задачи разрабатывается организацией, разработчиком программной продукции, на основании технического задания совместно с заказчиком. Главный исполнитель — это разработчик

2.Алгоритм-Последовательность действий, приводящих к результату.

Блок-схема- Графический записи алгоритма.

Исполнитель алгоритма-Человек, компьютер, автомат.

Язык программирования-Знаковая система для записи компьютерных программ.

Программа-Последовательность действий, приводящих к результату.

Объяснение:

Удачи тебе в учёбе!

0,0(0 оценок)
Ответ:
marinasok23
marinasok23
13.08.2020 05:55

II этап (Математическая модель)

S = πR², где

S - площадь круга

π - число пи (3.1415926)

r - радиус круга (окружности)

P = 2πr, где

P - Периметр круга (длина окружности)

π - число пи (3.1415926)

r - радиус круга (окружности)

III этап (Составление блок- схемы)

Смотри картинку

IV этап (Псевдокод)

алг z1

нач

вещ r,S,P,пи

пи:=3.1415926

ввод r

S:=пи*r**2

P:=2*пи*r

вывод S:0:3,нс

вывод P:0:3

кон

V этап (Программирование)​

program z1;

var r,S,P,pi:real;

begin

pi:=3.1415926;

write ('r = ');

read(r);

S:=pi*sqr(r);

P:=2*pi*r;

writeln ('S = ', S:0:3);

writeln ('P = ', P:0:3)

end.


3. Выполните поэтапное решение задачи.I этап (Постановка задачи).Вычислить площадь и периметр круга
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота