В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Vedma1338
Vedma1338
22.05.2021 03:32 •  Информатика

Написать программы в pascalabc 1. даны два числа. удвойте большее число, утройте меньшее число. 2. у васи было 300 рублей. он решил купить несколько шоколадных батончиков по некоторой цене. хватит ли у него денег? напишите программу, которая запрашивает количество батончиков и цену батончиков. в результате должен появиться ответ "хватит денег" или "не хватит денег" и сколько денег останется в случае, если денег хватит. если же денег не хватит, то вывести, какой суммы не достает.

Показать ответ
Ответ:
diana2010123456
diana2010123456
30.09.2020 14:44

Объяснение:

1.

var a, b: integer;

begin

read(a, b);

if a < b then

begin

a := a * 3;

b := b * a

end

else

begin

a := a * 2;

b := b * 3;

end;

print(a, b);

end.

2.

var kol, cen: integer;

begin

writeln('Введите количество и цену');

read(kol, cen);

if kol * cen < 300 then writeln('Хватит денег')

else writeln('Не хватит ', kol*cen - 300, ' рублей.')

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота