В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
SmartFox1
SmartFox1
06.07.2022 18:01 •  Информатика

Написать программы на языке python 1. введите с клавиатуры 5 положительных целых чисел. вычислите сумму тех из них, которые делятся на 4 и при этом заканчивается на 6. программа должна вывести одно число: сумму чисел, кратных 4 и оканчивающихся на 6 2.напишите программу для решения следующей . камера наблюдения регистрирует в автоматическом режиме скорость проезжающих мимо неё автомобилей, округляя значения скорости до целых чисел. необходимо определить максимальную зарегистрированную скорость автомобиля. если скорость хотя бы одного автомобиля была меньше 30 км/ч, выведите «yes», иначе выведите «n0».программа получает на вход число проехавших автомобилей n (1 < n < 30), затем указываются их скорости. значение скорости не может быть меньше 1 и больше 300.программа должна сначала вывести максимальную скорость, затем yes или no.

Показать ответ
Ответ:
alena7571
alena7571
26.05.2020 15:49

А самому, не?

1. def func():

i, summ = 0,0

while i < 5:

 i += 1

 x = int(input())

 if (x % 4 == 0) and (x % 10 == 6):

  summ += x

print(summ)

  func()

2.def speed():

n = int(input())

i = 0

maxSpeed = 0

text = 'NO'

while i < n:

 i += 1

 x = int(input())

 if x < 30:

  text = 'YES'

 elif x > maxSpeed:

  maxSpeed = x

print(maxSpeed, text)

 speed()

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота