В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
жанат17
жанат17
14.11.2022 22:06 •  Информатика

Написать программы на языке программирования Паскаль. 1) Компьютер запрашивает радиус круга и сторону квадрата. Надо определить, равные ли у них площади (ответ должен иметь вид: «Площади равные»). Если площади не равные, то выводится площадь меньшей фигуры.
2) Составить программу, которая запрашивает ввод температуры тела человека и определяет, здоров он или болен (здоров при 36 < t < 37)?
3) Числа Близнецы. Два нечетных простых числа, разнящиеся на два, называются Близнецами (5 и 7, 11 и 13, 17 и 19…). Составить программу, которая определяет, являются ли два введенных простых числа близнецами.

Показать ответ
Ответ:
egorkakraynov
egorkakraynov
05.10.2022 14:29

см.пояснение

Объяснение:

#include <iostream>

#include <cstdlib>

#include <ctime>

using namespace std;

const int n=499;

int main() {

   srand(time(0));

int arr[n],min=100,max=-100,iter=0,mediana;

for (int i=0;i<n;i++){

 arr[i]=rand()%200-100;

 if (min>arr[i])

  min=arr[i];

 if (max<arr[i])

  max=arr[i];

}

for (int i=0;i<n;i++){

 if(arr[i]==max)

  iter++;

}

int swap;

for (int i=0;i<n-1;i++){

 for (int j=i+1;j<n;j++){

  if (arr[i]>arr[j]){

   swap=arr[i];

   arr[i]=arr[j];

   arr[j]=swap;

  }

 }

}

mediana=n/2+1;

mediana=arr[mediana];

cout<<"min = "<<min<<endl;

cout<<"max = "<<max<<" povtorov: "<<iter<<endl;

cout<<"mediana = "<<mediana;

return 0;

}


Массив из 499 целых чисел заполняется псевдослучайными целыми числами от -100 до 100. Найти: - миним
0,0(0 оценок)
Ответ:
narenkovaa
narenkovaa
01.02.2023 00:19
Интернет - всемирная паутина, которая хранит в себе тонны информации. Он заменяет нам любой источник информации и облегчает понимание.
Газеты/журналы - письменные, или же стандартные получения информации на бумаге.
Телевидение - самый удобный источник информации. Содержит в себе и картинку, и звук, и приятную визуализацию.
Постеры/афиши - бумажки расклеенные по городу или же огромные постеры размещенные на зданиях. Очень привлекает внимание, тем самым увеличивает число интересующихся.
Радио - звуковая информация, уже перестает быть актуальной. В основном, радио - это не новости, а что-то более развлекательное.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота