Написать программы на C++
1 Задача
Напишите программу, которая выводит на экран трех различных уточек с символов псевдографики:
_ _ _
>(.)__ <(.)__ =(.)__
(___/ (___/ (___/
2 Задача
Факториал натурального числа n определяется как произведение всех натуральных чисел от 1 до n включительно и обозначается n!:
n!=1∗2∗3∗...∗n
Например, 3!=1∗2∗3=6.
Напишите программу, которая выводит на экран значение 10! (10 факториал).
с объяснением что вы пишите!
Код1:
#include <iostream>
using namespace std;
void duck(char dunck_nose) // функция рисует утку с введенным клювом
{
cout << " _" << endl; // рисует челку
cout << dunck_nose << "(.)__" << endl; // рисует голову с клювом в новом ряде
cout << " (___/\n" << endl; // рисует тело в новом ряду (\n делает отступ в ряд, как и << endl)
}
int main()
{
// у уток меняется только клюв, поэтому всунул их в функцию
duck('>'); // утка с ">" клювом и т.д.
duck('<');
duck('=');
return 0;
}
Код2:
#include <iostream>
using namespace std;
int main()
{
int sum = 1;
for(int i = 1; i <= 10; i++) // i = каждое число от 1 до 10
sum = sum * i; // умножаем сумму на каждое число
cout << sum; // выводим
return 0;
}
1) Задача:
#include <iostream>
using namespace std;
int main()
{ cout <<" "<<"_"<<" "<<"_"<<" " <<"_"<< endl;
cout <<">(.)__"<<" "<<"<(.)__"<< " "<< "=(.)__" << endl;
cout <<" "<<"(___/"<<" "<<"(___/"<<" "<< "(___/"<< endl;
return 0;
}
2) Задача:
#include <iostream>
using namespace std;
int main()
{
cout << 1 * 2 * 3 * 4 * 5 * 6 * 7 * 8 * 9 * 10 << endl;
return 0;
}
Объяснение:
Чел сверху написал нормальное решение, но сириус (если тебе нужно для него решение) не примет его так как есть запрещенные элементы. Самое глупое но работающее решение