В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Cancanich
Cancanich
15.06.2022 05:09 •  Информатика

Написать программу( желательно си++). Дана непустая последовательность литер, оканчивающаяся точкой.Определить, удовлетворяет ли она следующему свойству: последовательность совпадает с каким-то отрезком ряда 0123456789

Показать ответ
Ответ:
Проник755
Проник755
26.11.2020 11:05

#include <iostream>

using namespace std;

int main() {

string s;

string ss("0123456789");

getline(cin, s);

if(s[s.length()-1!='.']) {

 s+=".";

}

string temp;

for(int i = 0; i<ss.length(); ++i) {

 temp+=ss[i];

 if(s.find(temp)!=-1) {

  cout << "yes";

 return 0;

 }

}

cout << "no";

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота