В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
кор17
кор17
12.06.2022 07:15 •  Информатика

Написать программу (желательно на питоне) или на любом языке про температуру
: известны дневные и ночные температуры мая. определить дни, когда перепад
температур был максимальным.

Показать ответ
Ответ:
jokertop666
jokertop666
10.10.2020 06:56

Написано на Pascal

var

 Night:array [1..31] of integer ; //Массив с ночными температурами

 Day:array[1..31] of integer; //Массив с дневными температурами

 i,dif: integer;

begin

 dif:=0; // Разница

 for i:=1 to 31 do // Цикл заполняющий дневные и ночные температуры(Тут без отрицательных температур)

 begin  

   Night[i]:=random(30); // Рандомная ночная температура

   Day[i]:=random(30); // Рандомная дневная температура

 end;

 for i:=1 to 31 do // Цикл, который ищет максимальную разницу

   if (Day[i]-Night[i])>=dif then

   begin  

     dif:=Day[i]-Night[i];

   end;

 for i:=1 to 31 do // Цикл, который выводит дни с максимальной разницей

 if dif=(Day[i]-Night[i]) then

 writeln('Разница '+dif+'; '+i+' Мая');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота