В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
risha5239
risha5239
17.01.2022 21:03 •  Информатика

Написать программу,язык программирования - c++

Показать ответ
Ответ:
matveyking12345
matveyking12345
22.08.2020 01:26
Вот пример вычисления факториала числа 200

const
  n=1000; {максимальное количество цифр в числе}

type
  big=record
    v:array[1..n] of byte; {массив с цифрами числа}
    m:integer {количество цифр в числе}
  end;

function Str2Big(s:string):big;
{Переводит строковое представление в big}
var
  i,n,k,err: integer;
  r:big;
begin
  n:=Length(s);
  r.m:=n;
  for i:=1 to n do
  begin
    Val(s[i],k,err);
    r.v[i]:=k
  end;
  Str2big:=r
end;

function Big2Str(p:big):string;
{Переводит представление big в строковое}
var
  i,n:integer;
  c,s:string;
begin
  s:='';
  n:=p.m;
  for i:=1 to n do
  begin
    Str(p.v[i],c);
    s:=s+c
  end;
  Big2Str:=s
end;

function TruncBig(a:big):big;
{Усекает незначащие нули}
var
  i,p,n:integer;
  r:big;
begin
  n:=a.m;
  p:=0;
  while (p<n) and (a.v[p+1]=0) do p:=p+1;
  for i:=1 to n-p do r.v[i]:=a.v[i+p];
  r.m:=n-p;
  TruncBig:=r
end;

function MultBig(a,b:big):big;
{Возвращает произведение чисел типа big}
var
  i,j,k,m,n,s:integer;
  r:big;
begin
  m:=a.m; n:=b.m;
  for i:=m to m+n do r.v[i]:=0;
  r.m:=m+n;
  for j:=n downto 1 do
  begin
    if b.v[j]=0 then r.v[j+m+n-1]:=0
    else begin
      k:=0;
      for i:=m downto 1 do
      begin
        s :=a.v[i]*b.v[j]+r.v[i + j]+k;
        r.v[i+j]:=s mod 10;
        k:=s div 10
      end;   
      r.v[j] := k
    end
  end;
  MultBig:=TruncBig(r);
end;

var
  i:integer;
  s:string;
  bi,bs:big;
begin
  bs:=Str2Big('1');
  for i:=1 to 200 do begin
    Str(i,s);
    bi:=Str2Big(s);
    bs:=MultBig(bs,bi);
    end;
  s:=Big2Str(bs);
  Writeln(s)
end.

Результат
788657867364790503552363213932185062295135977687173263294742533244359449963403342920304284011984623904177212138919638830257642790242637105061926624952829931113462857270763317237396988943922445621451664240254033291864131227428294853277524242407573903240321257405579568660226031904170324062351700858796178922222789623703897374720000000000000000000000000000000000000000000000000
0,0(0 оценок)
Ответ:
113020021
113020021
24.10.2021 09:21

1. множество символов для записи текста называют алфавитом

2 полное количество символов в алфавите называют мощностью

3 за единицу информации при алфавитном подходе принято считать вес 1 символа алфавита

4 2

5 это вес 1 символа в двухбитном алфавите

6 информационный объем определяется по формуле I=K*i, где к-количество символов в тексте, а i - вес одного символа

7 8 бит

8 256 символов

9 потому, что он строится только на мощности алфавита

10 N- мощность алфавита, i -вес одного символа

11 алфавитный подход к измерению информации позволяет определить количество информации, заключенной в тексте

12 N=2^i

13 I=K*i, где К -количество символов в тексте, а i - вес одного символа

14 при алфавитном подходе смысл сообщения не учитывается, важно только какой алфавит использовался

15 количество информации, заключенное в сообщении, определяется объемом знаний, который несет это сообщение получающему его человеку. Сообщение содержит информацию для человека, если заключенные в нем сведения являются для этого человека новыми и понятными и, следовательно пополняют его знания.

16 сообщение, уменьшающее неопределенность знаний в два раза, несет для него 1 бит информации.

17

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота