В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
saitovdamir20Damit
saitovdamir20Damit
07.06.2020 12:25 •  Информатика

Написать программу! ! while и repeat 1)напечатать все отрицательные числа из диапазона от а до б, с шагом h. 2)напишите программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

Показать ответ
Ответ:
аринка129
аринка129
01.10.2020 16:56
1.program z;
var a,b,c:integer;
begin
read(a,b,c);
while (a<b) and (a<0) do
begin
write(a:4);
a:=a+c;
end;
end.
2.program z;
var a,b,c:integer;
begin
read(a,b,c);
repeat
write(a:4);
a:=a+c;
until (a>b) or (a>-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота