В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mrhack711ozvry4
mrhack711ozvry4
05.02.2021 00:04 •  Информатика

Написать программу, выводящую на экран поговорку «Ученье – свет, а неученье – тьма!» — 20 раз.

Показать ответ
Ответ:
198219821333
198219821333
13.04.2021 22:59

Если имеется в виду (a*b);

то будет 48

Тоесть такой код:

a=4; b=2; c=6

a=(a*b)*c

print(a)

Ну а если так:

Ну а если так:Выйдет ошибка:

Traceback (most recent call last):

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module>

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile)

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start exec(open(mainpyfile).read(), __main__.__dict__)

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start exec(open(mainpyfile).read(), __main__.__dict__) File "<string>", line 2, in <module>

Traceback (most recent call last): File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 31, in <module> start(fakepyfile,mainpyfile) File "/data/user/0/ru.iiec.pydroid3/files/accomp_files/iiec_run/iiec_run.py", line 30, in start exec(open(mainpyfile).read(), __main__.__dict__) File "<string>", line 2, in <module>NameError: name 'ab' is not defined

0,0(0 оценок)
Ответ:
artemmaslov25Artem
artemmaslov25Artem
10.07.2020 11:59

from random import randint

class G:

def __init__(self):

 self.wins = 0

def menu(self):

 print("stop - для остановки решения\nEnter продолжение.")

 while 1:

  if self.wins > 5:

   print("Ты хорошо справился, думаю на сегодня хватит")

   G.result(self)

   break

  a = input(": ")

  if a == "stop":

   G.result(self)

   break

  elif a == "":

   G.game(self)

  else: pass

def game(self):

 n1,n2 = randint(1,100),randint(1,100)  # примеры от и до

 print(f"Сколько будет: {n1} + {n2}?")

 if int(input("ответ: ")) == n1+n2:

  print("Верно")

  self.wins += 1

 else:

  print("Неверно")

 if self.wins != 5+1:

  print("Продолжим? Нажите Enter ля решения другого примера, введите stop для окончания")

def result(self):

 print("игра остановлена")

 print(f"Количество верных ответов: {self.wins}")

 if self.wins > 5:

  print("Молодец!")

 else:

  print("Потренируйся ещё")

a = G()

a.menu()


Напишите программу на python которая генерирует случайный пример на сложение двух чисел, например
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота