В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
89538277266
89538277266
09.10.2022 02:49 •  Информатика

Написать программу, выводящую на экран информацию по заданному образцу (на языке pascal): 100000000120000000123000000123400000123450000123456000123456700123456780123456789

Показать ответ
Ответ:
ykukharsp0dngs
ykukharsp0dngs
20.06.2020 09:54

program posledovatelnosti_cifr;

var i,j,k:integer;

begin

    for i:=1 to 9 do

    begin

         write(i);

         for j:=7 downto i-1 do write('0');

         writeln;

         for k:=1 to i do if i<=8 then write(k) else write();

    end;

end.

Скорее всего не самое оптимальное решение, но именно так получилось получить желаемый вывод.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота