В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
mashacat763p01bj9
mashacat763p01bj9
19.10.2020 07:15 •  Информатика

Написать программу, выводящую из таблицы значение озёр с самой маленькой и самой большой площадью.

Показать ответ
Ответ:
Iskrmsndrxjdjjsd
Iskrmsndrxjdjjsd
05.12.2021 04:19

ответ НА ПИТОНЕ ИЛИ С++

Задача 4: Американские горки

Аттракцион «Американские горки» представляет собой рельсовый трек, размещённый на опорах. Известна высота каждой опоры. Для рекламы аттракциона необходимо выделить один из его фрагментов (несколько подряд идущих опор с рельсовым треком) световой подсветкой. При этом необходимо выделить такой фрагмент трека, на котором была бы «горка» то есть на выделенном участке трека была бы точка, которая находилась бы строго выше начала и строго выше конца выделенного фрагмента трека.

Владелец аттракциона для экономии хочет найти подходящий участок минимальной длины, удовлетворяющий условию наличию «горки» на этом участке.

Входные данные

Первая строка входных данных содержит число N – количество опор аттракциона. Следующие N строк содержат информацию о высотах опор при движении от начала к концу аттракциона. Все числа натуральные, не превосходящие 105.

Выходные данные

Программа должна вывести два числа – номер первой и последней подходящей опоры. Опоры нумеруются числами от 1 до N. Если фрагмента, удовлетворяющего условиям, не существует, программа должна вывести одно число 0. Если подходящих ответов несколько, нужно вывести любой из них.

Система оценивания

Решение, правильно работающее только для случаев, когда все входные числа не превосходят 100, будет оцениваться в 40 баллов.

В 100 баллов будет оцениваться решение, правильно работающее, когда все числа не превосходят 105.

Примеры

Ввод Вывод Пояснение

7

18

10

15

20

20

10

3

3 6

Дано 7 опор с высотами 18, 10, 15, 20, 20, 10, 3. Самый короткий участок, содержащий «горку» – это 15, 20, 20, 10. Он начинается опорой номер 3 и заканчивается опорой номер 6.

3

9

8

5

0

Высоты опор убываю

Объяснение:

0,0(0 оценок)
Ответ:
Натульчик67
Натульчик67
09.09.2022 06:58

задача 3

Объяснение:

код написан на delphi/pascal

program Task3;

{$APPTYPE CONSOLE}

uses

 SysUtils;

const

 Alpha: set of Char = ['A'..'Z','А'..'П','Р'..'Я','a'..'z','а'..'п','р'..'я'];

var

 s: String;

 i: Integer;

 wc: Integer;

begin

 Readln(s);

 i := 1; wc := 0;

 repeat

   while not (s[i] in Alpha) and (i <= Length(s)) do Inc(i);

   if (i <= Length(s)) then Inc(wc);

   while (s[i] in Alpha) and (i <= Length(s)) do Inc(i);

 until i > Length(s);

 Writeln('Num words -> ',wc);

 readln;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота