Написать программу вывода матрицы в виде таблицы с разделением столбцов. (например, использовать символы «-» и «|»). внимание! программа написана, но надо переделать, чтобы она была с процедурами var i,j,n,m,k,t: integer; a: array[1..50,1..50] of integer; begin write('введите количество строк: '); readln(n); write('введите количество столбцов: '); readln(m); writeln('матрица: '); randomize; k: =m; for i: =1 to m do write(''); writeln; for i: =1 to n do begin for j: =1 to m do begin a[i,j]: =random(101)-50; write(a[i,j]: 6,' | '); end; writeln; for t: =1 to k do write(''); writeln; end; end.
#include <iostream>
#include <cstdlib>
#include <ctime>
#include <vector>
using namespace std;
int main()
{
int i, j, sum=0, n, m, p=1;
cout<<"Введите количество строк:"<<endl;
cin >> n;
cout<<"Введите количество столбцов:"<<endl;
cin >> m;
int k=i, h=j;
int a[n][m];
int max = a[0][0];
cout<<"Исходный массив:"<<endl;
for (i=0; i<n;i++)
{
for (j=0;j<m;j++)
{
a[i][j]=-10 + rand()%20;
cout<<a[i][j]<<" ";
}
cout<<endl;
}
for (i = 0; i < n; i++)
{
{
for (j = 0; j < m; j++)
{
sum += a[i][j];
}
cout<<"Сумма "<<i<<" строки равна: "<<sum<<endl;
sum = 0;
}
}
for (j = 0; j < m; j++)
{
for (i = 0; i < n; i++)
{
p *= a[i][j];
}
cout<<"Произведение "<<j<<" столбца равно: "<<p<<endl;
p = 1;
}
for(k=0, h=0; k<n && h<m; k++, h++)
{
if(a[k][h]>max)
{
max = a[k][h];
}
}
cout<<"Наибольшее число на главной диагонали: "<<max<<endl;
1. картинка
2. 2) палка
Объяснение:
1.
Общий порядок действий:
1) скобки
2) НЕ (¬, черта над выражением) - значение противоположно исходному высказыванию
3) И (∧) - истинно, когда оба исходных высказывания истинны
4) ИЛИ (∨) - ложно, когда оба исходных высказывания ложны
2.
(Первая буква слова согласная ИЛИ Вторая буква слова гласная) И Последняя буква гласная = 1 (истинно)
1) ирис
2) палка
3) словарь
И - истинно, когда оба исходных высказывания истинны
(Первая буква слова согласная ИЛИ Вторая буква слова гласная) = 1 (истинно)
Последняя буква гласная = 1 (истинно)
Проверим правую часть (Последняя буква гласная = 1 (истинно)):
1) ирис = 0 (ложно, с - согласная буква)
2) палка = 1 (истинно, а- гласная буква)
3) словарь = 0 (ложно, ь - не гласная и не согласная буква)
Осталось всего 1 слово (палка)
Проверим левую часть ((Первая буква слова согласная ИЛИ Вторая буква слова гласная) = 1 (истинно))
ИЛИ - истинно, когда любое из исходных высказываний истинно
Первая буква слова согласная = 1 (истинно)
ИЛИ
Вторая буква слова гласная = 1 (истинно)
2) палка = 1 (истинно, п - согласная буква, а - гласная буква)
1) ирис = 0 (ложно, и - гласная буква, р - согласная буква)
3) словарь = 1 (истинно, с - согласная буква, л - согласная буква)
Слово палка подходит и под левую часть