В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
CNikolas2001
CNikolas2001
27.11.2021 10:08 •  Информатика

Написать программу, вычисляющую стоимость покупки с учётом скидки: куплено 4 товара, если сумма превышает 2500р, то скидка составит 5%, если превышает 1300р, то скидка составит 3%​. Нарисовать блок-схему. Язык: Паскаль​

Показать ответ
Ответ:
Артемошка1111
Артемошка1111
30.05.2021 14:50

var

summa, skidka: real;

begin

writeln('Вычисление стоимости покупки с учетом скидки.');

writeln('Введите сумму покупки: ');

readln(summa);

 if summa >= 1300 then skidka:=3

  else if summa > 2500 then skidka:=5

   else if summa < 1300 then skidka:=0;

writeln('Вам предоставлена скидка ', skidka, '%');

writeln('Сумма покупки с учетом скидки: ', (summa-(summa*skidka)/100));

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота