В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ritkamargaritka1
ritkamargaritka1
05.01.2023 14:29 •  Информатика

Написать программу вычисления значения функции икс равно двенадцати а квадрат плюс семь а минус шестнадцать

Показать ответ
Ответ:
сонясонясоня1
сонясонясоня1
08.10.2020 06:11
Значение полиномов эффективно вычислять не "в лоб", а с использованием схемы Горнера.
x = 12a² + 7a - 16 = -16 + a(7 + 12a)

PascalABC.NET 3.3.5, сборка 1640 от 17.03.2018
Внимание! Если программа не работает, обновите версию!

begin
  var a:=ReadReal('a=');
  var x:=-16+a*(7+12*a);
  Writeln('x=',x)
end.

Пример
a= 5.18
x=342.2488
0,0(0 оценок)
Ответ:
belozerovanastya
belozerovanastya
08.10.2020 06:11
Var a,x: Integer;
begin
writeln('Введите значение числа a');
readln(a);
x:=12*(a*a)+7*a-16;
writeln('ответ: x=',x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота