В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
ByArts1000
ByArts1000
10.03.2021 14:04 •  Информатика

Написать программу вычисления: y = 1*6*11*16 … *(5n–4), n>0;

Программа в паскале, сайт

Показать ответ
Ответ:
Ушастый1209
Ушастый1209
30.12.2020 09:09
 const nx = 20;
var x: array[1..nx, 1..nx] of integer;z:array[1..nx*2] of integer; 
i, j, k,n,r,t: integer; 
begin 
Writeln('Введите размер матрицы n');Read(n); 
 for i := 1 to n do begin   
for j := 1 to n do begin   
Read(k);x[i, j] := k;  end;end;   
Writeln('Исходный массив'); 
for i := 1 to n do begin   
for j := 1 to n do begin     
Write(x[i, j]:4);     
if x[i, j]>0 then begin t:=t+1; z[t]:=x[i, j];end;    
end;   
Writeln;  end; 
Writeln;Writeln('Одномерный массив'); 
for j := 1 to t do     
Write(z[j]:4); 
 end.
0,0(0 оценок)
Ответ:
grange
grange
21.04.2022 17:14
// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var s:=ReadLnString('Вводите:');
  s.ToWords.Where(x->x=ReverseString(x)).PrintLn;
end.

Тестовое решение:
Вводите: дед иван достал наган и пошел с ним в шалаш
дед наган и с в шалаш

Вариант, если исключить однобуквенные:

// PascalABC.NET 3.0, сборка 1139 от 10.01.2016
begin
  var s:=ReadLnString('Вводите:');
  s.ToWords.Where(x->x=ReverseString(x)).
    Where(x->x.Length>1).PrintLn;
end.

Тестовое решение:
Вводите: дед иван достал наган и пошел с ним в шалаш
дед наган шалаш
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота