Войти
Регистрация
Спроси ai-bota
В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
Показать больше
Показать меньше
nafikovmarat539
06.02.2020 02:37 •
Информатика
Написать программу вычисления среднего n первых натуральных чисел
Показать ответ
Ответ:
приветЯ11
05.10.2020 22:51
#include<cmath>
#include<iostream>
using namespace std;
int main()
{
int N;
double P = 1;
cout << "N = ", cin >> N;
for(int A = 1; A<=N; A++)
P=P*A;
P = (N>0?pow(P,(double)1/N):0);
cout << "P = "<<P<<"\n";
system("Pause");
return 0;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
lty220051
09.10.2020 02:48
3. Для хранения 1 секунды звукозаписи звука, амплитуда которого измеряется 88 000 раз в секунду, а запись каждого результата измерения имеет информационный объем 16 бит, потребуется:...
AlyonaYarmak
22.12.2021 15:41
Известна средняя скорость движения поезда и расстояние от места его отправления до пункта назначения. Построить таблицу, отражающую зависимость расстояния до пункта назначения...
кек945
15.08.2022 13:37
Що є елементами графічного інтерфейсу windows...
орексе
05.05.2023 02:23
Какая функция у инструмента Тяни/Толкай? 1.Нарисуем окружность,поставив курсор на рабочую область 2.Рисуем дополнительно еще одну окружность 3.Тянем внутренню окружность...
Slado4ka
25.04.2021 11:35
Укажи масу розчину калій нітрату, з масовою часткою 8,3 %, який можна приготувати з солі масою 9 г....
MoonyGirl04
01.12.2022 19:34
Какие из приведённых памятников культуры были созданы в XVIII в.? Выберите два памятника культуры и запишите в таблицу цифры, под которыми они указаны Если сможете и с 9...
svetaredkina
30.01.2022 23:49
1344.Постройте графики прямой пропорциональности: ...
arinabesan6
23.05.2021 18:10
Внаслідок взаємодії біосфери, літосфери та інших зовнішніх оболонок Землі утворилось особливе природне тіло, що називається ......
POMIPO
21.11.2021 06:16
Физика 10 класс. Электромагнитная индукция/правило Ленца/Магнитный поток. Подробности на фото! 2 задачи !...
tdv84
04.08.2020 14:13
Чи є поезія Доля автобіографічний твором? Відповідь поясніть ...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
#include<iostream>
using namespace std;
int main()
{
int N;
double P = 1;
cout << "N = ", cin >> N;
for(int A = 1; A<=N; A++)
P=P*A;
P = (N>0?pow(P,(double)1/N):0);
cout << "P = "<<P<<"\n";
system("Pause");
return 0;
}