В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
1saridua1
1saridua1
14.03.2022 21:10 •  Информатика

Написать программу вычисления разговора по телефону с учетом 20% скидки, предоставляемой по субботам и воскресеньям. извне вводится длительность разговора(в целых минутах) и день недели цифрой (1--воскресенье). составить блок-схему к программе.

Показать ответ
Ответ:
annamironenkosp0dly3
annamironenkosp0dly3
29.07.2022 21:36
Не забывайте использовать автоформатирование CTRL+K+D

using System;
using System.Windows.Forms;

namespace Form1Namespace
{
    public partial class Form1
    {
        public Form1()
        {
            InitializeComponent();
        }

        private void Form1_Load(object sender, System.EventArgs e)
        {
            //Начальные параметры плиты
            // во первых названия должны быть не textBox1, а tbPlateWidth и тп, а то черт разберешь что куда
            textBox1.Text = "35";
            textBox2.Text = "40";
            textBox3.Text = "22";
            textBox4.Text = "30";
            textBox5.Text = "30";
            textBox6.Text = "10";
            textBox7.Text = "8";
            textBox8.Text = "7";
            textBox9.Text = "18";
            textBox10.Text = "8";
            textBox11.Text = "10";
        }

        private void button2_Click(object sender, System.EventArgs e)
        {
            // лучше писать в виде фильтров , а не многовложенных условий
            if ((textBox1.Text = "") || (textBox2.Text = "") || (textBox3.Text = "")
            || (textBox4.Text = "") || (textBox5.Text = "") || (textBox6.Text = "")
            || (textBox7.Text = "") || (textBox8.Text = "") || (textBox9.Text = "")
            || (textBox10.Text = "") || (textBox11.Text = ""))
            {
                MessageBox.Show("Заполните все поля!", "Внимание", MessageBoxButtons.OK, MessageBoxIcon.Error);
                return;
            }

            var PlateWidth = int.Parse(textBox1.Text);
            var PlateDiametr = int.Parse(textBox2.Text);
            var p3 = int.Parse(textBox3.Text);
            var p4 = int.Parse(textBox4.Text);
            var p5 = int.Parse(textBox5.Text);
            var p6 = int.Parse(textBox6.Text);
            var p7 = int.Parse(textBox7.Text);
            var p8 = int.Parse(textBox8.Text);
            var p9 = int.Parse(textBox9.Text);
            var p10 = int.Parse(textBox10.Text);
            var p11 = int.Parse(textBox11.Text);

            //пример проверки
            if PlateDiametr > PlateWidth {
                MessageBox.Show("диаметр отверстия не должен быть больше самой плиты", "Внимание", MessageBoxButtons.OK, MessageBoxIcon.Error);
                return;
            }

            //Метод создания плиты
            NewMacroNamespace.NewMacroClass.Plita(PlateWidth, PlateDiametr, p3, p4, p5, p6, p7, p8, p9, p10, p11);
        }

    }
}
0,0(0 оценок)
Ответ:
mariapopova77
mariapopova77
16.02.2020 05:51
#include <iostream>
using namespace std;
const int N = 8; //длина массива
double s = 0; //начальное значение суммы
double mas[N]; //объявляем статический массив длины N
int main()
{
    //вводим элементы массива
    for(int i = 0; i < N; ++i)
    {
        cin >> mas[i];
    }
    //пробегаемся по элементам массива
    for(int i = 0; i < N; ++i)
    {
        if(mas[i] != 0.0) //если элемент массива не равен 0
            s += 1. / mas[i]; //прибавляем значение обратного элемента к итоговой сумме
    }
    cout << s; //вывод суммы на экран
    return 0;
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота