Написать программу, вычисления , паскаль, вывести на печать значения функции z=x²+y+sin(x) при изменении х от –π до 0, с шагом π/6, и при изменении y от –1 до 1 с шагом 0,4.
Program Pr; var x,y,z:real; i:integer; Begin y:=-1; x:=-pi; For i:=1 to 7 do begin z:=x*x+y+sin(x); if (x<>0) then x:=x+(pi/6); if i=6 then x:=0; if y<>1 then y:=y+0.4; writeln('z=',z:4:4); end; end.
var x,y,z:real;
i:integer;
Begin
y:=-1;
x:=-pi;
For i:=1 to 7 do begin
z:=x*x+y+sin(x);
if (x<>0) then x:=x+(pi/6);
if i=6 then x:=0;
if y<>1 then y:=y+0.4;
writeln('z=',z:4:4);
end;
end.