В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
00Alcatraz00
00Alcatraz00
21.02.2021 01:45 •  Информатика

Написать программу вычисления объема пирамиды, в основании которой лежит треугольник со сторонами a, b, c. Высота пирамиды h. ОЧЕНЬ

Показать ответ
Ответ:
ikaerlapova
ikaerlapova
01.02.2023 17:28
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Ответ:
danishvika
danishvika
21.02.2021 10:37

Мета:

    навчальна: повторити правила поведінки в кабінеті інформатики актуалізувати вивчені раніше поняття: інформація, повідомлення, дані, інформаційний процес; сформувати поняття: кодування даних, декодування даних, передавач, приймач, канал зв'язку; сформувати вміння користуватися готовими системами кодування та розробляти власні системи кодування.    розвивальна: розвивати логічне мислення та креативність; сприяти розвитку логічного мислення, пам’яті, уваги і;    виховна: виховувати інформаційну культуру; виховувати уважність та відповідальність, бажання мати глибокі та якісні знання.Тип уроку: Комбінований.

Хід уроку

І. Організаційний етап

Повторення правил поведінки в кабінеті інформатики

ІІ. Актуалізація опорних знань

    Що таке інформація? (відомості про навколишній світ і явища, які в ньому відбуваються, називають інформацією.)    Хто чи що може бути приймачем інформації?  (людина, тварина, різноманітні пристрої)    Як людина сприймає інформацію? (Людина отримує інформацію  органами чуття )Як сприймають інформацію пристрої? (за до датчиків чи сенсорів.)    Що таке повідомлення? (Людина отримує інформацію з навколишнього середовища за до повідомлень)    Які бувають повідомлення за сприйняття, формою подання, за призначенням? (Тому за сприйняття повідомлення поділяють на зорові, смакові, нюхові, слухові і дотикові. Також повідомлення поділяють за формою подання — на текстові, числові, графічні, звукові, відео та комбіновані; за призначенням — на масові, спеціальні, особисті, наукові, технічні, розважальні тощо.)    Що називають інформаційними процесами? (Дії, які можна виконувати з інформацією, що міститься у повідомленні, називають інформаційними процесами. До них відносять зберігання, опрацювання, передавання, отримання, пошук, захист тощо)

ІІІ. Мотивація навчальної діяльності

Слово вчителя. Упродовж життя людина отримує безліч повідомлень, тому часто виникає потреба зберегти отримані знання або передати їх комусь іншому. Як це зробити?

IV. Вивчення нового матеріалу

Ще в прадавні часи люди опрацьовували інформацію, отриману з навколишнього середовища, і подавали її у вигляді наскельних малюнків. Зрозуміло, що передавати збережену таким чином інформацію було дуже незручно.

Ви знаєте, що інформація передається за до повідомлень, які можна подати текстовим, графічним, звуковим , а також відео, жестами та декількома одночасно — комбінованим повідомленням.

Для подання усних повідомлень ми використовуємо мову. А будь-яке письмове повідомлення складається з набору різних знаків (символів), які належать певному алфавіту. Наприклад, для подання числових даних використовують алфавіт, що складається з 11 знаків: цифр 0–9 і десяткової коми для відокремлення цілої та дробової частини в десятковому дробі.

Інформацію, подану у вигляді, прийнятному для передавання, опрацювання, збереження, називають даними.

Під опрацюванням даних розуміють такий інформаційний процес, в результаті якого ми отримуємо нові дані або дані, подані в інший іб.

Повідомлення передаються від джерела до приймача по каналах зв’язку. Після передавання повідомлення набувають вигляду, зрозумілого для приймача.

Під час розмови по телефону звукові сигнали (голос) перетворюються (кодуються) на електричні сигнали, які по мережі передаються до співрозмовника і знову перетворюються (декодуються) на звукові сигнали.

Людина постійно отримує, шукає, зберігає, опрацьовує й передає повідомлення. При цьому вона часто застосовує різні пристрої. Використання пристроїв зумовлює необхідність подання повідомлень за до спеціальних знаків.

Код — це система правил для перетворення повідомлень, що містять текст, звук, зображення, жести тощо.Кодування повідомлень — це процес перетворення за певними правилами одного подання набору даних в інший. Під час кодування повідомлення відбувається зміна вигляду повідомлення без зміни його  змісту.

У процесі обміну повідомленнями ми здійснюємо дві операції: кодування та декодування. Перша пов’язана з переходом від вихідної форми подання повідомлення у форму, яка є зручною для збереження, передавання або опрацювання. А друга — зі зворотним переходом до вихідного подання повідомлення. Отже,

Декодування — це перетворення закодованого повідомлення у форму, прийнятну для приймача.

Процес отримання та передавання повідомлень можна зобразити у вигляді схеми

.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота