В
Все
Б
Биология
Б
Беларуская мова
У
Українська мова
А
Алгебра
Р
Русский язык
О
ОБЖ
И
История
Ф
Физика
Қ
Қазақ тiлi
О
Окружающий мир
Э
Экономика
Н
Немецкий язык
Х
Химия
П
Право
П
Психология
Д
Другие предметы
Л
Литература
Г
География
Ф
Французский язык
М
Математика
М
Музыка
А
Английский язык
М
МХК
У
Українська література
И
Информатика
О
Обществознание
Г
Геометрия
FoxLove666
FoxLove666
11.10.2020 23:52 •  Информатика

Написать программу вычисления функции
f(x)=(20*x+4*c)/(67-y)
Значение x,y,c вводится с клавиатуры.
Функция вычисляется с подпрограммы.

Показать ответ
Ответ:
solopova08
solopova08
09.05.2020 17:06
/*
1. Описать класс с именем MARSH, содержащую следующие, поля:
• BEGST — название начального пункта маршрута;
• TERM — название конечного пункта маршрута;
• NUMER — номер маршрута.
2. Написать программу, выполняющую следующие действия:
• ввод с клавиатуры данных в массив TRAFIC, состоящий из 3 элементов типа MARSH;
• вывод на экран информации о маршруте, номер которого введен с клавиатуры;
• если таких маршрутов нет, выдать на дисплей соответствующее сообщение.
*/

#include <iostream>
using namespace std;

class MARSH
{
public:
string BEGST, TERM, NUMER;

MARSH(string b, string t, string n)
: BEGST(b), TERM(t), NUMER(n)
{
}

MARSH() {}

void info() {
cout << "Маршрут №" << NUMER
<< " (" << BEGST << '-'
<< TERM << ')';
}
};

int main()
{
MARSH TRAFFIC[3];
string b, t, n;
for (int i = 0; i < 3; i++) {
cout << "Ввод данных для маршрута " << i << ':' << endl;
cout << "Название начального пункта маршрута: ";
cin >> b;
cout << "Название конечного пункта маршрута: ";
cin >> t;
cout << "Номер маршрута: ";
cin >> n;
cout << endl;
TRAFFIC[i] = MARSH(b, t, n);
}
cout << endl << "Введите номер маршрута: ";
cin >> n;
MARSH m;
for (int i = 0; i < 3; i++) {
m = TRAFFIC[i];
if (m.NUMER == n) {
m.info();
return 0;
}
}
cout << "Нет маршрута с таким номером!" << endl;
return 1;
}
0,0(0 оценок)
Ответ:
ярик471
ярик471
24.09.2021 05:06
Var
a,b,c,p:real;
Begin
Write('a = ');Read(a);
Write('b = ');Read(b);
Write('c = ');Read(c);
if (a<b+c)and(b<a+c)and(c<a+b) then
Begin
if (a=b)and(a<>c) then Write('Треугольник равнобедренный, ')
else if (a=b)and(b=c) then Write('Треугольник равносторонний, ')
else if (a*a=b*b+c*c)or(b*b=a*a+c*c)or(c*c=b*b+a*a) then Write('Треугольник прямоульный, ')
else Write('Треугольник никакой, ');
p:=(a+b+c)/2;
a:=sqrt(p*(p-a)*(p-b)*(p-c));
Write('его площадь равна ',a);
End
else Write('Треугольник не существует')
End.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота